contact_form does not work

mewickham Member
edited February 23 in Plugins

contact_form does not work

Zenphoto 1.5.1; Theme: Basic, dark

  1. I activated the contact_form plugin.
  2. I activated the PHPMailer plugin.
    I feel like I've tried every possible option for PHPMailer, but clicking the "Send e-mail" button on a filled-out form results only in an error page:

    This page isn’t working
    <mysite.com> didn’t send any data.
    ERR_EMPTY_RESPONSE

Can someone point me toward a fix? I have GoDaddy cPanel hosting.

Comments

  • acrylian Administrator
    edited February 24

    If you are sure you entered the right credentials for the phpmailer options (especially that using a mail provider), please try the sendmail plugin instead. That would use the native PHP mail facility on your server. If that also does not work it may not be configured. Then you need to contact your host about that.

    The plugin itself works, we use it on our own site (with sendmail)

  • fretzl Administrator
    edited February 24

    I notice you get similar errors for what appear to be different issues.
    (https://forum.zenphoto.org/discussion/comment/1981302)

    So I Googled around a bit and it looks like it may be a Google Chrome thing.
    I found this page on how to fix Google Chrome connection errors.
    https://www.easytechguides.com/google-chrome-connection-errors.html

    Btw: We checked and double checked the contact_form, PHPMailer and user_login-out plugins and they all work fine.

  • Thank you for the leads. I will check them out, although I am not sure it is a Google Chrome thing, as the same thing happens with Microsoft Edge.

  • acrylian Administrator

    Yes, I am also pretty sure it is a server side issue.

  • I got busy and didn't deal with this until now, but I got it working. I had to use a different email address and mail server. For some reason, the email addresses using the site server fail. So I will figure that out next. Thanks for the help!

  • swf Member

    I used that host myself and the problems they have were simply too much for me to deal with. Their support of Zenphoto is very poor.

Sign In or Register to comment.