zenphoto 1.5.1: Creation of new user impossible: "password may not be empty"

Hey,
I have installed ZP 1.5.1 in Ubuntu 18.10 using PHP 7.2, Apache 2.4.34 and MySQL 5.7. I made sure all prerequisites are fulfilled and every tiny bit of the config is correct.

I also created an admin user. After that I wanted to create a restricted user but that fails every time. The error message is "password may not be empty" - which doesn't make sense because I entered the password, also in the repeat password field, of course.

This behaviour can be reproduced, I tried it on another server running Ubuntu 18.04.

Comments

  • acrylian Administrator
    edited April 12

    I am sorry but I cannot reproduce this on our own server with our own site which is also Linux Ubuntu as far as I can see.

    Please review the Zenphoto logs and if you can your server PHP error log.

  • ctdlg Member

    Hello zpnewbie1.
    I tried on my linux machine and it does work : user is created.
    But,
    I'm running PHP7.1

  • acrylian Administrator

    @ctdlg Thanks for testing as well. PHP 7.2+ is absolutely fine, we do work and test on that as well.

Sign In or Register to comment.