zpArdoise: Disable slideshow from automatically starting

MBchrono Member
edited April 18 in General support

Howdy!

I am pulling my hair out trying to figure this out. I can't pretend to be an expert or anything, but I have looked through just about every config file I can thing of, and cannot figure out how to disable the slideshow from starting when I open an image in my gallery.

Website: http://www.mattandshelby.com
Example: http://www.mattandshelby.com/MBchrono/zenphotoslideshow.jpg

I've provided an example above. In the top right of the image you can see the slideshow is already starting. I want you to have to manually start it. I am using the zpArdoise theme. Am I missing something extremely simple?

Any help would be appreciated!

Thanks!
Matt

Comments

  • acrylian Administrator
    edited April 18

    I am not familar with zpArdoise. But that the slideshow opens on thumb click is a specific zpArdoise thing. That surely its author @vincent3569 can answer (I edited the topic title to include the theme name).
    But I assume that you will have to modify the theme by chaning the colorbox JS defines. http://www.jacklmoore.com/colorbox/

    The standard slideshow2 plugin always uses a button and also does not have any option to disable autoplay because that's the usual expected behaviour.

  • fretzl Administrator

    You probably have checked the Use Colorbox in Album page option in your theme's options

  • acrylian Administrator

    @fretzl I think @MBchrono does want the colorbox instead of image page. Just without the slideshow feature. That is possible but requires theme change if VIncent does not have any option to disable it already.

    Perhaps the current theme has already as @Mbchrono is still on Zenphoto 1.4.14. Vincent will tell soon :-)

  • fretzl Administrator

    Ah yes. Sorry.

  • vincent3569 Member
    edited April 19

    hi
    with colorbox, you have 2 main options for slideshow.

    slideshow : If true, adds an automatic slideshow to a content group / gallery (default value: false).
    slideshowAuto : If true, the slideshow will automatically start to play (default value: true).

    1- if you don't want a slideshow, set slideshow option to false. then you always have to manually change picture.

    2- if you want a slideshow with a manual start, add slideshowAuto option to false. then the slideshow doesn't start automatically and you have to manually start it.

    to do that, you have to edit inc_header.php, line 218 (colorbox config).

    1-

                    slideshow: false,
    

    2-

                    slideshow: true,
                    slideshowAuto: false,
    
  • Thank you everyone for your quick responses, very much appreciate it!

    Vincent, I found the lines you mentioned and the slideshow is working as I want it to now. Thanks so much! :smile:

Sign In or Register to comment.