Upgrade issues with 1.5.4

Hi
I got a message form Softaculous that Zen was outdated and needed updating so I selected the upgrade icon.

After step one where it copied some files I said you have one step remaining.....

I then clicked on the setup link and get

Parse error: syntax error, unexpected ')', expecting T_PAAMAYIM_NEKUDOTAYIM in /home/fiveofha/public_html/Zen/zp-core/functions-basic.php on line 1878

Any help would be appreciated.

Craig

Comments

  • acrylian Administrator

    We can't help with Softalaculous itself. Could be permissions or something else.

    I have to recommend to follow the manual update process as described here: https://www.zenphoto.org/news/installation-and-upgrading/

    There is nothing wrong with the line in question as far as I can see. But also check that your server matches the requirements.

  • acrylian Administrator

    I guess you have a PHP version older than 5.5. The test !empty(WEBPATH) in the line in question could trigger that error on outdated PHP versions like this. Please ask your host to upgrade to at least 5.6 or even better 7+. T

  • craigh Member

    Thanks I will give that a try.
    This is the version previously

    Zenphoto version 1.4.14 [f5b47da52f] (Official build)
    Current locale setting: en_US.UTF8
    Server path: /home/fiveofha/public_html/Zen
    WEB path: /Zen
    PHP Session path: /tmp
    Current gallery theme: Revised Basic
    PHP version: 5.3.29
    Graphics support: PHP GD library bundled (2.1.0 compatible)
    supporting: gif, jpg, jpeg, png, wbmp
    PHP memory limit: 768M (Note: Your server might allocate less!)
    MySQLi version: 5.6.40
    Database name: fiveofha_zen928
    Table prefix: zpyu_
    Spam filter: No spam filter configured
    CAPTCHA generator: zpCaptcha
    Site status: The site is opened

  • acrylian Administrator
    edited August 16

    PHP version: 5.3.29

    That confirms my thought above. You will have to upgrade PHP.

    Also note that this is a minor-major update so perhaps first upgrade to 1.5. instead of directly 1.5.4. Especially since you seem to use a customized theme.

    Btw, if posting system data best anonymize parts like database name or server paths. It's not the full info for anyone to use but just to be on the secure side.

  • craigh Member

    Thanks for the help. I checked and PHP had been locked at an old version. I updated it and setup ran fine.

    Thanks Again

  • craigh Member

    Also I did not choose the option to delete files that are no longer used as part of the install. Can I go back and clean up manually or is there a script ?

  • acrylian Administrator

    You can re-run setup any time from the backend. But check manually which files are listed. Actually if you followed the upgrade process there should not be files not used at least not in zp-core.

Sign In or Register to comment.