Error 500 with Wordpress Importer plugin

Hi, I'm a new ZenPhoto user (just installed it a few days ago) and I'm trying to switch from a Wordpress site to a ZenPhoto one. So I tried the Wordpress importer plugin. No errors during installation, but when I click the Wordpress Importer button on the admin page I get HTTP ERROR 500 saying my site is currently unable to handle this request. I realise the plugin isn't supported, but I don't know php so I hope I've missed something easy/obvious :)

I had a look around for some error logs and found a php.error.log file with the following:

[17-Aug-2019 13:37:07 Europe/London] PHP Warning: require_once(SERVERPATH/ZENFOLDER/admin-globals.php): failed to open stream: No such file or directory in /home/dmstrach/public_html/site/plugins/wordpress_import.php on line 40
[17-Aug-2019 13:37:07 Europe/London] PHP Fatal error: require_once(): Failed opening required 'SERVERPATH/ZENFOLDER/admin-globals.php' (include_path='.:/opt/cpanel/ea-php71/root/usr/share/pear') in /home/dmstrach/public_html/site/plugins/wordpress_import.php on line 40

In Cpanel I found these entries in the error logs, the time stamps look around the same time I was trying the plugin. Both files are part of my Wordpress install, ZenPhoto is installed at public_html/site/

[Sat Aug 17 14:44:51.833236 2019] [access_compat:error] [pid 13448] [client 103.131.71.36:46549] AH01797: client denied by server configuration: /home/dmstrach/public_html/index.php
[Sat Aug 17 14:44:51.832916 2019] [access_compat:error] [pid 13448] [client 103.131.71.36:46549] AH01797: client denied by server configuration: /home/dmstrach/public_html/robots.txt
[Sat Aug 17 08:37:14.465519 2019] [access_compat:error] [pid 8683] [client 103.131.71.185:41351] AH01797: client denied by server configuration: /home/dmstrach/public_html/index.php
[Sat Aug 17 08:37:14.465187 2019] [access_compat:error] [pid 8683] [client 103.131.71.185:41351] AH01797: client denied by server configuration: /home/dmstrach/public_html/robots.txt

Is there anything I can do to fix this problem?

Thank you :)

Comments

  • acrylian Administrator

    There was indeed a path wrong. Please try the update from the repo.

    I think it should generally still work as intended as the db structure both of Zenphoto and WordPress should still match its code.

  • The update worked perfectly, everything seems to have imported successfully.

    Thanks a lot for such a quick fix, it's much appreciated :)

Sign In or Register to comment.