Images not visible in admin

Zenphoto version 1.5.4 (Official build)
Current locale setting: en_US.UTF8
PHP version: 5.6.40
Graphics support: PHP GD library bundled (2.1.0 compatible)
supporting: gif, jpg, jpeg, png, wbmp, webp
PHP memory limit: 4096M (Note: Your server might allocate less!)
MySQLi version: 5.6.45

I have logged into the web site after some time to try to sort out a query from the person running the web site.
If I click on Albums - I can see the list of albums with the number of albums and images in each.
When I click on image order, I can see all the images in that folder
I click on an individual album with, say, 50 images listed as being in it (and which I can see from the front end)
if I click on images I can't see any images - the album appears to be empty of images.
They are visible on the frontend but not in the backend.
I have never come across this before.
(the last time I logged in, some time ago, they were visible)

Thank you for any help you can offer,
Richard

Comments

  • acrylian Administrator

    I have no idea, it cannot really be that you see them on the frontend and not the backend… If it was a dynamic albums there would be no images on the backend but there would not be an images tab either. What do the logs say?

    PS:

    PHP memory limit: 4096M (Note: Your server might allocate less!)

    Does your server really provide that much? That would be great of course ;-)

  • Thank you - the only problem reported in the logs were a couple of bare words in my adaptations in the template code - I corrected those - though I can't see that they would have affected the backend code.
    But, whatever, I can now again see the images under the Albums - Images section - perhaps it was some sort of cache problem.
    Now I can work on the actual problem reported to me!

    Many thanks,
    Richard

    PHP memory limit: Does your server really provide that much?

    Yes, it does.

  • acrylian Administrator

    All right. Sometimes it's the browser cache that plays tricks on you. The ZP backend does not use any page caching.

    Also: Whenever you think albums or images don't match your files, use the "Refresh the database" utility. That forces to update/sync the db with the albums/images on the file system.

    Now I can work on the actual problem reported to me!

    Anything we can help with as well or your site specific?

Sign In or Register to comment.