Full size images not loading

The first 3 albums I created worked fine. But the last 2 days, none of the large images are showing, tho' the thumbnails do. (http://dutchbarns.org/zphotos/)

I'm using php 7.2. and imagick. The memory limit is 128M. I tried setting the
post_max_size and the upload_max_filesize to 1G, per your guide. The file permissions are all 755.

But nothing helps. I'm at a loss.

These are the errors I'm getting in the logs since the problem started:

WARNING: Division by zero in /home/www/dutchbarns.org/zphotos/zp-core/admin-thumbcrop.php on line 299
{33472:Fri, 25 Oct 2019 11:23:28 GMT}

EXCEPTION (8192): Methods with the same name as their class will not be constructors in a future version of PHP; ThemeOptions has a deprecated constructor in /home/www/dutchbarns.org/zphotos/themes/zpbase/themeoptions.php on line 10 require_once called from admin-options.php [2664] {43743:Fri, 25 Oct 2019 12:54:09 GMT}

NOTICE: Undefined index: albumimagesort_status in /home/www/dutchbarns.org/zphotos/zp-core/admin-edit.php on line 418 {45455:Fri, 25 Oct 2019 12:55:42 GMT}

Comments

  • acrylian Administrator
    edited October 25
    1. I believe this is due to bad meta data and the images not having their width/height stored correctly. Try to re-save them locally with some image editor and re-upload them directly via FTP so you overwrite the former one.

    2. You are using an old version of the zpBase theme. You can get an updated with this fixed here: https://github.com/zenphoto/zpbase/releases

    3. I believe this is fixed in 1.5.5 already. You are using 1.5.4. Note 1.5.5 has a bug sneaked which breaks the jquery uploader. The support build (= 1.5.6b) has this fixed already

  • Thanks for your help.
    I re-saved the images from Gimp and overwrote the images with FTP. But it didn't help.
    I re-installed the zbase theme from the link you gave me. It said it was v.1.1.1, I didn't see a 1.5.5
    I still can't get the full-size images to load.

  • I looked at the database, and I see that all the images have a height and width listed, but for a lot of them the filesize is NULL. I'm pretty sure those are the ones where the large images are not loading. Why does it not know the filesize and how do I get it to figure or recognize that?
    Thanks

  • acrylian Administrator

    The filesize is normally read on various occasions like backend editing or importing images. Are there any file/folder permission issues in the logs possibly?

  • Actually, the filesize column in the database is used ONLY by the quota_manager plugin. (Of course, the size of the file is stored there so that quota_manager can use it. But this may not happen if quota_manager is not enabled.)

    But bottom line, the value of the filesize field has no bearing on your images not loading.

  • acrylian Administrator

    Even if not used and not important by itself it is read - in the meaning of imported - from images on some occasions and not being read "might" indicate some yet unknown issue somewhere.

    @hvvaweb I see you switch themes meanwhile so I cannot try a full image of yours locally. Did that change anything?

  • perhaps you missed this:
    "But this may not happen if quota_manager is not enabled."

    Besides which, the value, IF it is saved, is got from the PHP filesize() function which "Returns the size of the file in bytes, or FALSE (and generates an error of level E_WARNING) in case of an error."

    So, there is no way the value of the field can be NULL unless it was never set in the first place as the quote above suggests.

    There may well be an unknown issue somewhere, but it has nothing to do with the filesize field being NULL.

  • acrylian Administrator

    True indeed.

  • This is really weird. If I use the Base template, I can see both the albums and the large images. But if I use the zbase template, which is my preference for a responsive one, it won't load the large ones.

  • acrylian Administrator

    Thanks, then we might have a theme issue here. We will try to reproduce that.

  • fretzl Administrator
    edited October 30

    I could not reproduce this but in the zpbase theme I found and fixed a few "undefined variables" in some JavaScript. Please try the latest version of zpbase.

Sign In or Register to comment.