Installation impossible

Hihaho Member
edited March 14 in General support

Bonjour et merci d'avance pour vos réponses (désolé d'écrire en français mais je peux lire l'anglais).

Je viens de télécharger zenphoto 1.5.6 et je rencontre la difficulté suivante avec la configuration : "La base de données zenphoto n’a pu être créée. [La requête CREATE DATABASE a échoué.] "
Or ma db existe sur localhost. Elle est vide. Je l'ai supprimée, mais zenphoto ne la crée pas davantage !

J'utilise mysql via phpMyAdmin (port 3308 dixit wamp64) sur localhost avec identifiant root et sans mot de passe.
On me dit que zenphoto "essaiera" de configurer la base mais je n'ai aucun moyen de transformer cet essaie raté... (pas de bouton "Go" ou "OK", etc.)
Je suis donc bloqué... et mes 2h de navigation sur le net pour trouver une solution n'ont pas été productives vous êtes donc mon ultime recours...

Encore merci.

Comments

  • acrylian Administrator, Developer
    edited March 14

    Sorry, the forum is English only. Please post again.

    But quickly to this:

    port 3308 dixit wamp64)

    You have to use the standard port 3306 for MySQL instead.

  • Hihaho Member

    I think it's the reson? I tried to write 3306 in config, but, for WAMP, 3306 is reserved for MariaDB...
    My DB on mysql already existed.
    And under the form there's no link like OK or Go.
    sorry for my english... and thank you for your answer

  • acrylian Administrator, Developer

    3306 is reserved for MariaDB... My DB on mysql already existed.

    Currently there is no way to define the port for the database in Zenphoto to use. There generally is a default server side taht is used, in your case it uses MariaDB. But Zenphoto should also work with MariaDB in compatible versions so perhaps you can just migrate it?

  • Hihaho Member

    Thank you for this answer, but I have already a (relativly good) knowledge of mysql... I'll try this if there isn't alternativ...
    I'm going to see on and with Wamp how to change this...

  • Hihaho Member

    Yeah !
    I've decoching (?) Maria BD in parameters of Wamp, then I could call a new port in mysql server...
    It's running, thank you. But, there is a "but"..., in the scrip of zenphoto shouldn't you let the choose of the port...

    Good luck !

  • acrylian Administrator, Developer

    Well, Zenphoto is meant to run on standard servers/webhost that normally only have one database server so there is never a need to choose the port. However we will look into adding that.

  • acrylian Administrator, Developer
    edited March 15

    Please try the support build/master (=1.5.7b) from GitHub as it now allows setting the mysql port.

    Add $conf['mysql_port'] = "3308"; to the other database credentials within your install's zp-data/zenphoto.cfg.php to try and re-run setup. Testing this would help us.

  • Hihaho Member

    I've done. It's running.

Sign In or Register to comment.