Internal Server Error on Admin access

Since this weekend, I'm encountering a a major problem: Everytime I try to call my admin area, I get an "Internal Server Error". The webhoster (netcup in Germany) did some upgrade, but refuses to help or give any kind of information here, which could help to figure out the problem. Reason: Internal Server Errors are totally in the response of the custommer. On the other hand, I did not change anything in my Zenphoto installation.

The webpage itself (www.spottair.de) is running as normal. Only the admin area causes the problem. Can anyone please give some hint, where to search for the problem. I'm not so experienced with such problems? Thank you.

Comments

  • acrylian Administrator, Developer

    Hard to say but I would suspect file/folder permissions. Why these may have changed I have no idea. Could be that the host did some internal updates like moving hosting accounts to a new server. Did they announce anything?

    Also please review your error logs.

  • Hi, the error logs show the follwoing:

    2020-06-02 13:30:05 Error 2003:cd:9f07:9b00:fdaf:de4e:a289:b40a 500 GET /zp-core/admin.php HTTP/1.0 Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_6) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/13.1.1 Safari/605.1.15 903 Apache-Zugriff

    2020-06-02 13:30:05 Error 2003:cd:9f07:9b00:fdaf:de4e:a289:b40a AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace. Apache-Fehler

    2020-06-02 13:30:05 Error 2003:cd:9f07:9b00:fdaf:de4e:a289:b40a AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace. Apache-Fehler

    2020-06-02 13:41:11 Error 66.249.66.24 500 GET /robots.txt HTTP/1.0 Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html) 899 Apache-Zugriff

    2020-06-02 13:41:11 Error 66.249.66.24 AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace. Apache-Fehler

  • acrylian Administrator, Developer
    edited June 2

    I have no real idea… Do both /admin/ and /zp-core/admin.php not work? What PHP version do you have on your site? What updates did the host do?

  • They updated the hosting panel and the operating system, they said. Also, they removed all PHP version before 5.6. Version 5.6 will be kept with reduced functionality (what ever that means). Could the php version change to such an error and how can I detect, which version is currently used by my ZENPhoto installation, now that my admin is no longer working?

    And - yes, both Admins are no longer working.

  • acrylian Administrator, Developer

    You should generally be able to see what PHP version you use on your host's panel. Otherwise you can see that via phpinfo() by putting a file e.g. info.php with it into the root of your domain and call it (remove it later for security).

    If not 7+ I suggest to switch. I also see that you use the libratus theme. If you use the original also keep an eye on https://github.com/zenphoto/libratus as we - if made aware - will fix at least bugs of it.

  • ChristianS Member
    edited June 2

    Currently, PHP version is configured to 7.4.3 on the host. And yes, the libratus thema is pretty old. But for me it's still perfect ;-)

    In the meantime, I wrote a support request to my webhoster. I hope I will get some useful information.

  • acrylian Administrator, Developer

    We had a similar issue like yours a while back but that was before 1.5.6. https://forum.zenphoto.org/discussion/comment/1981701#Comment_1981701

    And yes, the libratus thema is pretty old. But for me it's still perfect ;-)

    Then best upldate to the one we host as well. It has not much changes just at least one tiny change regarding some php 7 deprecation.

    In the meantime, I wrote a support request to my webhoster. I hope I will get some useful information.

    Hopefully they will be able to help.

Sign In or Register to comment.