Installer is consistently in French.

Hello,

I've tried searching the forums and github for a way to fix this, but didn't find anything that I could particularly follow.

For some reason, a freshly downloaded copy of this script insists on presenting me with an installer in French. My browsers are all set to accept just en_US, no other languages. My hosting provider is located in the US, so it seems reasonable to think that everything is set for en_US, but everything is in French.

I can understand some of the installer by way of context, but would be happier being able to fully run the installer in a language I am fluent in, to make sure I am doing everything right.

Is there some option that I have overlooked or otherwise failed to find that would allow me an option to run the installation process itself in English?

Thank you for your time.

Comments

  • acrylian Administrator, Developer

    That's really weird as en_US is the native language. Did you ever use it before? Do you see a language selector with flags at the bottom of the setup script? Language selection is also stored in a cookie. I would try to clear cookies in the browser used to see if that thas any effect.

  • Xial Member

    I have not used it with this host before. Everything was unpacked in a freshly made directory.

    I unfortunately do not see a language selector at the bottom of the installer page, and I've also given clearing cookies a go as well as even trying the installer in Microsoft Edge and Brave Browser to isolate the issue away from my local browser installs.

    All browsers come up consistently in French on the installer; the two Chromium-based ones offer to translate, and my Gecko based one (Waterfox) does not.

    As such, I have not even completed the install.

  • Xial Member

    A bit of an update: I manually entered my database information into the ./zp-data/zenphoto.cfg.php file, and upon reloading the installation page, while it first presented in French, I was presented with a series of language flags at the bottom that I could choose from.

    I had started feeding the installer's French text to a translator, and it wanted me to secure a file that was set 0644 instead of 0600. This is where and when I spotted the config file, and decided to go for broke in filling in my database info.

    Any time I refresh the page to follow an instruction that I can now read in English, it does revert to French, requiring me to change it back to English.

    I did start to step through the install, and after pressing the Go button for install, it switched back to French. When the installer completed and I worked my way through the pages in French, I can see in the overview that somehow:

    Current locale setting: fr_FR.UTF8
    

    The locale info page shows me this:

    Http Accept Languages
    
    The locales your browser has defined to accept.
    Key     code    coef    morecode    fullcode
    1.0-en  en  1.0     US  en_US – English (United States)
    0.5-en  en  0.5         en – English
    

    The PHP info page, under Environment, also shows en_US, which leads to my further confusion on the fr_FR.

  • acrylian Administrator, Developer

    I have sadly no idea right now why you see everything in French. I have never encountered anything like this before.

    If you managed to install please go to Options > General and see what langauge is selected there as the default. On a fresh install that probably should indeed be http accept language (where French does not make sense here). Select English there explicity and disable all other languages.

  • Xial Member

    Apologies for the late reply.

    I did manage to finish the install, and and HTTP Accept Language was the default. I did disable all other languages, and now have just English as the presented language.

    I am not certain as to the cause, but next time I have spare time, I should try a fresh install to see if I can recreate the issue in another folder on the same host.

    Thank you. :)

  • acrylian Administrator, Developer
    edited October 26

    No problem at all ;-) If HTTP Accept Language was enabled ZP should actually use what the browser requests. If that was not French I have no idea why this would happen. Just to ask are you sure that you haven't enabled more than one langauge in the browser. I ask because I have German and English enabled in some for example and it then uses the first naturally.

Sign In or Register to comment.