Zenphoto will not display since changing locale

vstam Member
edited April 5 in General support

Hi,
I have been using Zenphoto for a long time at http://greekorchidsociety.org/gallery/ I currently have the latest version installed 1.5.7 and the website is located on a shared server.

Recently, we experienced an issue with displaying correctly some characters. I changed the locale to an option I do not recall (I know...) using the dropdown option on the admin page. Since then, the front and admin pages will not display at all. I have re-run the installation script and it installs successfully, but the issue persists. If you visit http://greekorchidsociety.org/gallery/ you will see the problem.

The error log is [05-Apr-2021 12:13:18 Europe/Athens] PHP Warning: htmlspecialchars(): charset `UNICODE' not supported, assuming utf-8 in /home3/pandelis/public_html/gallery/zp-core/functions-common.php on line 308

I have explored where to change the setting in the database and the config file but have had no success. Has anyone here got any suggestions? I suppose I could remove the installation completely and import the database, albums and theme, but I would prefer to avoid that. Thank you, Vas

Comments

  • fretzl Administrator, Developer

    I see a normal (but a bit slow) working website with language in Greek.

  • acrylian Administrator, Developer
    edited April 5

    I see only Chinese chars and even the source code. There is a PHP core issue with translations/locale currently: https://www.zenphoto.org/news/translations-gettext-not-working-on-some-servers/

    But that should not be related to your issue. Without the above bug only locales works that are installed on the server. You should then get the nativ English version though.

    Recently, we experienced an issue with displaying correctly some characters

    Looking at the error you didn't change a locale but the charset. "UNICODE" is indeed not a valid charset.

    Zenphoto has two options the general charset and a filesystem charset. Both should be "UTF-8" generelly (unless you really know you need another).

    Look into your installs database options table and find the entriy for "charset" and "filesystem_charset" and change the value to "UTF-8". Try to see if that helps.

    Do the db entries otherwise look as they should? If not there might be an issue with the database (it happens rarely but they can go corrupt being just files on the server…)

    Also there might also be some other server misconfiguration involved. There are lots osf charset like the communication with the database, the native file system and such. If the above db change does not help I would also contact the host.

  • vstam Member

    Acrylian, THANK YOU! I changed the values on the database directly (phpMyAdmin) from UNICODE to UTF-8 and my website now works.

    Fretzi, thank you too for responding.

  • acrylian Administrator, Developer

    Great!

Sign In or Register to comment.