Google not index album photos in the pages?

cenkgoksel Member
edited May 24 in General support

Im using zpbase theme. When i search on the google pages are index but photos not index.
Thats why google start delete to pages be couse not seen photos in abums and thinking copy pages.
İ think couple of Only thumb size photos indexted 298 x 298 size. Did i do mistake somewhere can anyone help me please how to fix problem.
Im i doing someting wrong in the settings?
This is some of photos from my website google index.

https://images.app.goo.gl/M5HKYkokpifS9fKr7

Only 298 X 298

My Web site
https://www.fdream.co.uk/

Thanks very much waiting your helps please.

Tags:

Comments

  • acrylian Administrator, Developer
    edited May 24

    There are lots of reasons why Google may not index something we cannot tell about. If a site is new it might take a while as GOogle has internal priorities what to index.

    Some general observations:

    • The images on your site seem not to be cached yet. This happesn once and may slow down the site which may make google to not index it. Please read here about the image cache: https://www.zenphoto.org/news/caching/
    • Use modrewrite, it is not mandatory but helps with SEO.
    • Use the static_html_cache plugin to speed up the site
    • generate a site using the sitemap plugin (and add it to the robots..txt or submit it to Google directly if you have an account)
  • Thanks very much for your helping Acrylian its was realy helpul and i fix many problems google index my all pages. But still google index images only thumb size i try change all options didnt fix problem yet is there any options am i still doing wrong?
    Is there any change can google index my full size photos? Or even bigger than only thumb size?

  • acrylian Administrator, Developer

    It is really hard to tell why they are not indexed. Sometimes only google knows.
    Did you check the robots.txt?

    Generally your album pages are a little slow because you show all images at once. https://www.fdream.co.uk/index.php?album=collection takes 1.5 minutes to load ( and even some images don't work) even with already cached images. Speed is an important measure for Google.

    • Use pagination (images per page) to lower what has to be loaded instantly.
    • Try more compression on the thumbs
    • Again: Use modrewrite, it is not mandatory but helps with SEO.
    • Again: Use the static_html_cache plugin to speed up the site
    • (Perhaps get a faster server/webhost)
Sign In or Register to comment.