Can't Access site - or admin please help

I have a site I can't reach. Been out of the game for a bit and checking in on the site and it's not loading. Was working not too long ago.
http://www.davidsonscollisioncenter.com/

I can access images and stuff and FTP to the files seems fine. I did check the debug.log file and see this as recent...

{885104:Sat, 05 Jun 2021 13:53:16 GMT} Zenphoto v1.4.11[26c78176cfb8d752e9e7bda4e65d69fc84b714a3]
EXCEPTION (8192): Methods with the same name as their class will not be constructors in a future version of PHP; zenpagecms has a deprecated constructor in /home4/n20capri/public_html/www.davidsonscollisioncenter.com/zp-core/zp-extensions/zenpage.php on line 105
require_once called from require_once (load_objectClasses.php [35])
from require_once (functions.php [33])
from include (index.php [14])
from index.php [28]

Not sure how to proceed - PLEASE assist.
Regards,
Mike

Comments

  • acrylian Administrator, Developer

    Yout Zenphoto version 1.4.11 is from 2015,13 versions behind and not compatible with PHP 7+. I assume your webhost has updated the server with current PHP versions about which you surely have been informed about beforehand.

    In general frequently update your install to avoid this.

  • n20capri2 Member
    edited June 6

    Damn which is the last version it would work with? Thanks

    And is there anything I can do in the meantime w/o upgrading to get this site back up besides changing PHP versions? Host might not let me

  • acrylian Administrator, Developer
    edited June 6

    Damn which is the last version it would work with? Thanks

    Not sure what you mean.The current version 1.5.8 should work. That would be PHP 5.6.x. 1.4.11 is not even the latest 1.4.x which would be 1.4.14. Of course there are changes with 1.5.x but the longer you wait the more will add up. How much work that is for you I cannot say as I naturally don't know your site in detail. Test on a staging site before the update on the live site and review the logs for errors.

    You can rename consturctor as the exception tells but this is only a workaround and willl either lead to similar followup and other issues.

    You really should update Zenphoto instead of switching to an outdated PHP version as all below 7.3 are already not maintained anymore.

  • n20capri2 Member
    edited June 6

    What do you mean rename constructors? It's been so long since I've worked with Zen I forget the process...and w/o back-end access I'd be afraid something (worse) will go wrong. It's a pretty custom site. lol I'll see what I can do...Thanks

  • acrylian Administrator, Developer

    The update instructions are still the same and noted on our site. Regarding your custom code I naturally cannot help.

    If you don't have a staging site - which you really should have e.g. locally via WAMP, MAMP or the like - you have to take the chance and try it and work through the errors from the logs.

    Better do this now as most things still the same and frequently in the future. It most certainly will get more complicated in the future.

  • n20capri2 Member

    My host was able to roll back PHP on this site for me and all is ok for now. I have instructions on what worked for me before on how to upgrade but it's been a while idk if it will still work...We'll see what I can do

Sign In or Register to comment.