zpBootstrap dissappeared from cachemanager

zpBootstrap is my main theme, but it has disappeared from the cache manager plugin. I tried switching themes, but this did not trigger it to show up. How do I trigger it to show up in cache manager?

All aspects of my site are upgraded to latest software.



  • acrylian Administrator, Developer

    Image sizes are registered to the cachemanager in a theme's themeoptions.php file. zpBootstrap is actually setup correctly as far as I can see.

    I can only recommend to review your error logs.

  • Is there a manual method I can use to register zpBootstrap with the cache manager be editing my database. I have tried everything and the theme sizes refuse to register with cachemanger. I entered the sizes manually in cachemanger, but those sizes disappeared after an upgrade.

    Any help greatly appreciated.

  • acrylian Administrator, Developer
    edited July 2021

    The best way is to register the sizes via the themeoptions.php. See the zenpage theme one for an example.

    Documentation is here:

    Actually zpBootstrap does already register sizes, although those are just the default ones. I am not familar enough with the theme to know if there are more.

  • Well, I understand that. But it is not getting me closer to a solution.

    I have noticed another anomaly. When I use the cachemanager it shows image sizes for a theme I have not used for several years, (and is not in the theme folder) but it refuses to show images sizes for a new theme which I have added and subtracted numerous times (trying to trigger its appearance).

    That is why I asked where the cachemanger database for image sizes is, bc it clearly is not updating.

  • acrylian Administrator, Developer

    When I use the cachemanager it shows image sizes for a theme I have not used for several years, (and is not in the theme folder)

    That can happen indeed but is not much of an issue since you can disable them. You should alos be able to delete these on the plugin options.

    If you looked at the code you will see that it uses plugin_storage which all plugins do unless its options.

    But you should aboid changes in the database itself,directly instead the issue must be solved. If there is one. So I need to reproduce if you eitehr use something wrong or there is a bug.

    Please post the complete code how you register the sizes on your theme.

  • Just an FYI concerning zpBootstrap and cach_manager. Due to my recent testing I have 2 fresh installs of ZP and zpBootstrap. I noticed that ZP bootstrap NEVER registers with the cache-manager.

    I previously created custom sizes in the cache manager matching zpBootstrap sizes, which worked fine but they disappeared after an upgrade.

    I know Vincent is AWOL but thought I should add to this thread.

  • acrylian Administrator, Developer

    The original theme does not register properly anymore but our fork does: https://github.com/zenphoto/zpBootstrap/commit/6d8c02ad110018226f47bc62580cbda4e0be8a85

  • Ok got it working locally and live. After reinstalling the fork. Sorry for the confusion.

  • acrylian Administrator, Developer

    No problem! It is a bit confusing that the original is not updated anymore.

Sign In or Register to comment.