I can't enable https

guirala Member, Translator

Hi friends:
After having migrated my website to another provider (which was successful), I run into a problem; in the "Security" section I can't enable "https". Although I choose that option, it does not change it and remains in http. I have my correct SSL certificates, I enter the backend or the site page correctly in https, but when I log out of the backend it loads me the initial page of the site but with "http" indicating "site not secure". This happened to me since the migration (despite the fact that before doing it I already had the site secured) and it remains in the same conditions even after updating to 1.5.9.
Did I do something wrong? How do I correct it?
Thanks.

Comments

  • acrylian Administrator, Developer
    edited July 9

    Even if you set the option it will set the actual value in the zp-date/zenphoto.cfg.php file. Perhaps an issue with file/folder permissions prevents that . There might be something in the debug log.

    You can open the config file directly via FTP in a texteditor. Then find the line $conf['server_protocol'] = "http" and change the value tohttps`. Then it should work.

  • guirala Member, Translator

    OK, thanks Acrylian.
    It was fixed by editing zenphoto.cfg.php as you suggested. Now it works correctly.

Sign In or Register to comment.