images don't show up - broken link symbol

Using theme ZBase - which I think is the best Zenphoto theme: I hope you are keeping it up to date - I use it on 4 zenphoto websites.

But sometimes, with one of these sites, the image itself, ie. image.php , shows up just as a broken link.

https://genza.org/kerke-churches/

I have re-run setup several times and I think all images are now showing but I have not looked at them all.

This query is in case it happens again.

Have you experienced this - any clues as to what causes it?

Many thanks,
Richard

Comments

  • acrylian Administrator, Developer
    edited July 28

    I hope you are keeping it up to date - I use it on 4 zenphoto websites.

    We are not actively maintaining zpBasei but will try to fix bugs (on https://github.com/zenphoto/zpbase).

    The Page you liked above is not reachable for me, the whole site is not:: SSL_ERROR_UNRECOGNIZED_NAME_ALERT

    I have to use http instead of https which then leads to https://genza.org.za/index.php/en/ instead which is a Joomla and not a ZP site at all.

    So something is not right with the SSL certificate and some redirections server side.

    Regarding broken images the first thing you need to do is review the logs. COmmon issues are noted here: https://www.zenphoto.org/news/problems-with-albums-and-images/

  • RichardB Member

    Thank you - I provide the wrong url - apologies.
    I have looked at the page you indicated
    am working on it again.
    Seems to me one gets a notice now and then that you need to re-run setup because something has changed - don't know whether the change can cause the images not to show but at the moment re-running setup seems to have cured the problem - for how long I don't know.
    Richard

  • acrylian Administrator, Developer

    Seems to me one gets a notice now and then that you need to re-run setup because something has changed

    That behavior is explained on our installation page. And no that has nothing to do with images not showing up but with an internal catalogue (unless you installed an actual update). Images not showing up is most always a processiong/server power thing.

  • RichardB Member

    I have read your imaging problems page and the memory was already at 128MB - the other increases, which I made, were for uploading large files and large zipped files, which is not a concern here.

    I was concocting a screen shot of a page with broken link to image which took some time - the page with all text and details appears but the image shows as a broken link - if there are several images in the album the left and right arrows appear too - I spent some time on this - came back to the actual page, clicked on an arrow and, lo and behold the images were now there!

    This web site is from a restore - so that I can play around with it - so the cache was cleared prior to back up - seems to me the cached images are taking a verrrry long time (minutes) to regenerate - what would cause this?

    As per your image problem page the memory limit has been set to 128MB but it could be set higher if required - do you think that would help?

    You wrote earlier: Regarding broken images the first thing you need to do is review the logs

    which logs and where are you referring to - the debug logs? No errors seem to be appearing there

    If you go to this album:

    https://genza.org.za/test_zenphoto/index.php?album=Gauteng/GAU-KRUGERSDORP

    there are 15 albums on that page - each contains one or more images - go into any of the albums and then click on an individual picture - that is when I am getting the broken link for the image.

    Thanks,
    Richard

  • acrylian Administrator, Developer
    edited July 29

    I just clicked into some albums and I didn't see any broken images.

    More memory helps always if you are allowd to change that. On shared hosting you surely not. It really depends on the server power as well. If you are on a shared hosting server you share the power with other people.

    Generally this processing issue will appear for uncache images that need processing and not later when they are caching. Seems that most albums I open have uncached images initially.

    which logs and where are you referring to - the debug logs?

    Yes, the ZEnphoto debug log but also the PHP error log on the server itself (Where that Is I cannot tell, it differs on hosts).

    Besides you are still 1.5.1 (not that I think this really matters in this case)

  • fretzl Administrator, Developer

    I see what you mean. In my browser console I see that fetching the images is forbidden [403]. Can't tell why sadly.

  • RichardB Member

    Thank you fretzi - when I inspected it via Chrome - I found this in the Console:

    index.php:53 Mixed Content: The page at 'https://genza.org.za/test_zenphoto/index.php?album=Gauteng/GAU-KRUGERSDORP/GAU-KRUGERSDORP-Krugersdorp-Oos-Simfonie-Apostoliese-Geloof-Sending-Kerk&image=GAU-KRUGERSDORP-Krugersdorp-Oos-Simfonie-Apostoliese-Geloof-Sending-Kerk_02.JPG' was loaded over HTTPS, but requested an insecure stylesheet 'http://fonts.googleapis.com/css?family=Open+Sans'. This request has been blocked; the content must be served over HTTPS.

    I will invetigate,
    Richard

  • acrylian Administrator, Developer

    That should be fixed indeed but this actually blocks that script/the fonts being loaded and not the images. 403 is file/folder permission related actually.

  • RichardB Member

    I corrected the http in the header.php and image-popup.php in zpBase theme, but still get the problem - chrome inspect now tells me:
    i.php:1 Failed to load resource: the server responded with a status of 403 (Forbidden)
    Any idea what that may be caused by?

    Many thanks,
    Richard

  • acrylian Administrator, Developer
    edited July 29

    As already mentioned 403 is a error related to file/folder permissions. Why that occurs I have no idea.

  • RichardB Member

    I asked the support from the webserver hoster if they could help - this was the reply:

    The above URL is redirecting the corresponding gallery such as Kwazulu-Natal, Eastern-Cape.

    In this case, it is redirecting to another image that is not present in the server. The images are redirecting the location "/home/genza/public_html/test_zenphoto/albums/Western-Cape/WK-BELLVILLE"

    Please check the redirection to the correct gallery name to solve the error.

    --

    does that mean anything to you? It doesn't to me.

    I went and had another look at the above link web site - in the theme general options I ticked the box for 'mod rewrite'.
    This seems to have solved the problem if I view the site in Chrome but the problem still occurs in Edge and IE and Firefox.

    It must be something to do with the template zpBase - if I use your official templates it works just fine - will have to try to develop one of them - but they are unfortunately not responsive.

    Thanks,
    Richard

  • acrylian Administrator, Developer

    The URL https://genza.org.za/test_zenphoto/index.php?album=Western-Cape/WK-BELLVILLE/WK-BELLVILLE-Vredelust-Boston-Kampus-Nederduitse-Gereformeerde-Kerk is an album page URL and not an image URL at all. If it was for an image it would have &image= additionally. These are in any case non rewritten "legady" URLs..

    The album URL indicates that this is a 2nd level subalbum:

    0 Western-Cape/
    1. WK-BELLVILLE/
    2. WK-BELLVILLE-Vredelust-Boston-Kampus-Nederduitse-Gereformeerde-Kerk

    That is no redirection "/home/genza/public_html/test_zenphoto/albums/Western-Cape/WK-BELLVILLE" is the actual URL of the album on the file system, note the "albums" within it.

    As you say it may be zpBase. The former developer of it made a few things off the standard back then.

    And yes all included themes are out of fashion. Sadly we have not yet time to create a new one but there will be at least one some time in the future.

  • acrylian Administrator, Developer

    On a quick look the only thing that could cause trouble here is some JS resizing so the image is in the middle. That may cause some trouble, not sure. The original author did a few rather off things under the hood I fear…

  • RichardB Member

    Still investigating!

    I note that within this website I have two installations of Zenphoto

    If I check Options/General

    The one causing me problems has a note:

    Setup did not detect a working mod_rewrite facility.

    whereas the other, which runs fine using zpSkeleton as theme, has no such note in Options/general

    Each has an identical htaccess file (apart from base directory) with
    RewriteEngine On - these were created by Zenphoto

    in one installation the rewrite is (apparently) detected but not in the other.

    Any suggestions please?

    Thanks,
    Richard

  • acrylian Administrator, Developer

    Sorry, cannot help. The check performed is alwys the same: Setup tries of a rewritten link works via a JS request. Sadly there is no real other relable way than testing an URL and even that is not really. If you have it enabled and rewritten URLs work you can just ignore this.

  • Thank you.
    Still don't know what the problem was but have installed a new instance of Zenphoto, copied the album folder and the database from the original and it seems to work OK now. Upgrade to 1.5.9 from 1.5.1 seems to have worked OK (thank you).

    In the debug log I am getting a series of warnings like that printed below - all to do with cachemanager. I can't work out if these are triggered by code in the theme (zpBase) - I can't find it being used in the theme code - or in the ZenPhoto app itself.

    {28691:Sun, 01 Aug 2021 09:47:28 GMT} Zenphoto v1.5.9

    USER WARNING: deleteThemeCacheSizes (called from cacheManager.php line 941) is deprecated Use cacheManager::deleteCacheSizes() You can disable this error message by going to the deprecated-functions plugin options and un-checking deleteThemeCacheSizes in the list of functions. in /home/genza/public_html/new_kerke-churches/zp-core/zp-extensions/deprecated-functions.php on line 158

    trigger_error called from deprecated_functions::notify (deprecated-functions.php [158])

    from cachemanager_internal_deprecations::deleteThemeCacheSizes (deprecated-functions.php [34])

    from cacheManager::deleteThemeCacheSizes (cacheManager.php [941])

    from ThemeOptions->ThemeOptions (themeoptions.php [87])

    from admin-themes.php [38]

  • acrylian Administrator, Developer

    The last two lines tell it is the theme. You are not using the latest version of the theme: https://github.com/zenphoto/zpbase

  • Thank you - much appreciated
    Richard

  • I ended up with the zpBase (and the Collections) theme working OK in Chrome, but in Edge or IE the image showed up as the broken link (zpBase) or a never-ending 'workinig on it' in Collections.

    By accident I was able to resolve this - in zpBase custome theme options - width of site - I had 1300.

    If I reduce this to 1200 or less the image shows up.
    In Garland - if I make the image size too large we also get the broken link.
    In theme Collections the image size is set to 2200 - I am unable to alter the size in its theme options so do not know if a change in size would stop the spinning 'working' symbol.

  • acrylian Administrator, Developer

    That sounds to me as if the size like 1300px was just to large and probably upscaling the image causing your server not being able to handle this. This is any case something that needs to be figured out individually as all server are different.

    I cannot help with the Colections themes. You probably have to modify it. Perhaps try to contact its author, perhaps via its GitHub repo: https://github.com/RolandTi/collections/issues

    IE is really not a browser anyone should and does still pay atention to. You wil have issue with that everywhere by now. It is totally outdated and Edge the successor already (which I don't know being a Mac user)

Sign In or Register to comment.