Upgrading to 1.6a from 1.5.9 broke filepath

Hi,
Despite the warning (I like risk...), I have updated my web site from 1.5.9 to 1.6a from the support branch.
Since, all images that have a special character or a space in file path is not found anymore. It used to work fine :neutral:

Example :
Erreur Zenphoto : l’objet demandé n’a pas été trouvé.
Album : 2020-2029/2021/Viequotidienne
Real file path is 2020-2029/2021/Vie%20quotidienne/

It seems that it is related to the function sanitize_path that has been modified. Is there a way to fix that? Is there a new parameter in the backend in 1.6?

Comments

  • acrylian Administrator, Developer
    edited July 30

    Yes, that function was modified, read about why here please:
    https://forum.zenphoto.org/discussion/1410824/invalid-album-instantiation#latest

    It might not be perfect yet, which is why it is a alpha version :-)

    Generally I strongely recommend not to use any special chars or spaces within folder/filenames because it can cause all kind of trouble.

    We may make cleaned folder/filenames mandatory at some point if uploading from the backend as currently it is a plugin doing this. This is what most CMS do as well.

  • acrylian Administrator, Developer

    We have decided to revert our actually more secure change to avoid this behaviour. Still it is a good idea to seocleanup folder and filenames.

  • Yes, thanks. It solves the problem ;-)
    I will keep as long as I can my naming friendly readable (including spaces and accents etc) as it is a mirror of my source repository exported by LightRoom.
    I will check in the future if I can sanitize it when exporting it.

  • acrylian Administrator, Developer

    Always keep in mind that the name (= URL) and the title (= website) are independent.

Sign In or Register to comment.