Setup fails with Table creation failure, error 168

I am attempting to setup zenphoto for the first time (v.1.5.9, now several attempts today) on a self-hosted ubuntu server running Apache2 2.4.41-4ubuntu3.4, PHP 2:7.4+75, and MySQL 5.8+1.0.5ubuntu2. During setup, I get to this point:

Zenphoto Setup Setup
Checking the database

About to create database tables...

Begin database table creation

failureTable creation failure:
Query: CREATE TABLE IF NOT EXISTS `_captcha` ( `id` int(11) UNSIGNED NOT NULL auto_increment, `ptime` int(32) UNSIGNED NOT NULL, `hash` varchar(255) NOT NULL, PRIMARY KEY (`id`) ) CHARACTER SET utf8 COLLATE utf8_unicode_ci;
Error: Got error 168 - 'Unknown (generic) error from engine' from storage engine

failureTable creation failure:
Query: CREATE TABLE IF NOT EXISTS `_options` ( `id` int(11) UNSIGNED NOT NULL auto_increment, `ownerid` int(11) UNSIGNED NOT NULL DEFAULT 0, `name` varchar(191) NOT NULL, `value` text, `theme` varchar (127) NOT NULL, `creator` varchar (255) DEFAULT NULL, PRIMARY KEY (`id`), UNIQUE (`name`, `ownerid`, `theme`) ) CHARACTER SET utf8 COLLATE utf8_unicode_ci;
Error: Got error 168 - 'Unknown (generic) error from engine' from storage engine``

Plus several more of these, until...

failureTable creation failure:
Query: CREATE TABLE IF NOT EXISTS `_search_cache` ( `id` int(11) UNSIGNED NOT NULL auto_increment, `criteria` TEXT, `date` datetime default NULL, `data` longtext, KEY (`criteria`(255)), PRIMARY KEY (`id`) ) CHARACTER SET utf8 COLLATE utf8_unicode_ci;
Error: Got error 168 - 'Unknown (generic) error from engine' from storage engine

Begin table updates

Done with table create with errors!

Checking table specifications

Research shows error 168 may refer to full storage, but root has 83GB available. Any suggestions?

Tags:

Comments

  • As a side note, I would love if the installation guide was more detailed.

  • acrylian Administrator, Developer
    edited August 23

    I have not seen or encountered this error before. Research also suggest is may have to be related to MySQL permissions.
    https://dba.stackexchange.com/questions/217776/error-in-query-1030-got-error-168-from-storage-engine-when-creating-table

    I currently have no idea about that other than suggest to check the permissions of your mysql user. Was there any other report during setup or in the setup log (you should find that in /zp-data of your install)

    As a side note, I would love if the installation guide was more detailed.

    Actually there is not more to explain, it is normally that simple.Zenphoto is aimed as failry standard configured shared hosting and at least to me works without any issue on half a dozend of such hosts I regulary update site on. What exactly are you missing?

  • Computer didn't survive a reboot (frozen at splash screen, ignoring Esc), so something major happened. Reinstalling Grub got me to a root shell only. Planning to reinstall Ubuntu at this point.

  • acrylian Administrator, Developer

    That sounds as if you have a general issue with our server setup perhaps. I cannot help with that as II don't setup my own servers.

  • Had major issues, it turns out. Had to reinstall everything, and now zenphoto installed fine. I'll open another thread on install guide requests.

Sign In or Register to comment.