Error

Aeswere Member
edited September 1 in General support

Hi, I recently had reinstalled zenphoto after wanting to try other image galleries, and not finding anything that had what I wanted, upon trying to reinstall it, my error_log file is filled with the same error:

[01-Sep-2021 00:05:30 UTC] PHP Fatal error:  Uncaught Error: Call to a member function getCode() on int in /home/username/public_html/gallery/zp-core/functions-common.php:27
Stack trace:
#0 [internal function]: zpErrorHandler(2, 'filesize(): sta...', '/home/aeswerec/...', 1333)
#1 /home/username/public_html/gallery/zp-core/functions-basic.php(1333): filesize('/home/username/...')
#2 /home/username/public_html/gallery/zp-core/functions-common.php(420): debugLog('EXCEPTION (0): ...')
#3 /home/username/public_html/gallery/zp-core/functions-common.php(54): debugLogBacktrace('EXCEPTION (0): ...', -1)
#4 [internal function]: zpErrorHandler(1)
#5 {main}
   thrown in /home/username/public_html/gallery/zp-core/functions-common.php on line 27

Which I believe is also causing the issue of a white page with nothing on it. At first with a status 500 error, and now I get a 200/302 but still the same white page. As well as the favicon. I have also never had this issue before.

Edit: Apparently the issue was caused from PHP 8.0. Changing back to 7.3 displays pages as normal. No idea why it does that.

Comments

  • sbillard Member
    edited September 1

    You got it right. Zenphoto does not yet support PHP 8.0 :(

  • acrylian Administrator, Developer

    Yes, which is documented on our install and requirements page. PHP 8 support is coming soon.

Sign In or Register to comment.