Blank screen after upgrading to 1.5.9

I just upgraded to 1.5.9 (followed the instructions to the T). I went to my main page to run setup, but it was blank. Even navigating to the "www.yoursite.org/zenphoto/zp-core/setup.php" yielded a blank page. The file is there, permissions as they should be. No idea what's going on.

PHP Version is 7.4.20.

Comments

  • acrylian Administrator, Developer

    Please review the debug log and your server php error log.

  • halben Member
    edited November 11

    Debug Log:

    {23658:Wed, 10 Nov 2021 16:17:00 GMT}
      WARNING: mysqli::query(): (HY000/3685): Illegal argument to a regular expression. in /home/dh_k84i36/mydomain.net/gallery/zp-core/functions-db-MySQLi.php on line 84 
    mysqli->query called from query (functions-db-MySQLi.php [84]) from query_full_array (functions-db-MySQLi.php [130])
    from SearchEngine->searchFieldsAndTags (class-search.php [1081])
    from SearchEngine->getSearchImages (class-search.php [1544])
    from SearchEngine->getImages (class-search.php [1626])
    from SearchEngine->getNumImages (class-search.php [1509])
    from getNumImages (template-functions.php [2097])
    from include (search.php [9])
    from include (index.php [130])
    from index.php [56]
    
    {6104:Wed, 10 Nov 2021 19:35:39 GMT}
      EXCEPTION (0): syntax error, unexpected '<', expecting end of file in /home/dh_k84i36/mydomain.net/gallery/zp-core/functions-db-MySQLi.php on line 400
    

    The error log repeats the same "Illegal argument to a regular expression. in /home/dh_k84i36/mydomain.net/gallery/zp-core/functions-db-MySQLi.php on line 84"

    Just a note: I'm no expert when it comes to PHP. I have experience working with it, but no formal training. (I know just enough to get into trouble, it seems.) Simple explanations are appreciated.

  • acrylian Administrator, Developer

    We'll try to give simple answers when possible ;-)

    The lines your logs reference seem to indicate a problem with the mysql database configuration or credentials you entered.

    Please check the credentials you got from your webhost and check if you have them defined correctly in zp-data/zenphoto.cfg.php.

  • Thanks, I really appreciate that :)

    I checked my credentials in the file, all looks normal. My webhost updated their PHP version about a month ago, but my gallery was running on it just fine.

    I just noticed something strange going on in my phpMyAdmin (my databases not showing up in the list, which has happened once before) and I've contacted my webhost about it. But I could see the databases when I was trying to troubleshoot this problem yesterday, so I really have no idea what the issue might truly be here.

  • acrylian Administrator, Developer

    I am sorry, PHP 7.4.20 should work (8 does not yet). But if the databases / the database server were gone temporarily that could explain such issues. Guess we'll have to see what the host says…

  • I haven't heard back from my host yet, but the PHP upgrade was indeed to 8. (Uh oh.) This was about mid-October. However, I ran a PHP version check on my site just yesterday (and I tested it just now), and it still says 7.4.20. I think I may install the previous ZenPhoto version just to get my gallery up and running again. Once I can see my databases again, of course. Thank you very much for your help thus far.

  • acrylian Administrator, Developer

    Ok, let us know if you find out anything.

  • Nothing wrong with my host; the databases appeared again after a few minutes.

    I just tried installing 1.5.7 (after a failed attempt to install 1.5.8), which I think was the last working version I had before I tried to upgrade, but it yielded the same problem with the blank pages (as it did with 1.5.8). The debug log reads this same error several times:

    {13770:Thu, 11 Nov 2021 14:39:12 GMT}
    EXCEPTION (0): syntax error, unexpected '<', expecting end of file in /home/dh_k84i36/mydomain.net/gallery/zp-core/functions-db-MySQLi.php on line 400

    The weird thing is, the file "functions-db-MySQLi.php" doesn't even have a line 400. It only goes to 376 in ZenPhoto 1.5.7, the version I have currently installed. (Unless these errors are slow to log? Because I was trying to install 1.5.7 around 11pm New York time and this last entry was from 9:39am.)

    I'm beginning to think a fresh install is my only hope. I have my database and custom themes and albums backed up, but I have horribly slow internet and limited data (it's all I can get out where I live, unfortunately), so if there's a way I can somehow do a clean install of ZenPhoto without having to delete all 200+ images in my albums, that would be wonderful. Would that even work?

  • acrylian Administrator, Developer
    edited November 12

    I see indeed two possibilites right now: Either something is not right on the configuration on your host somehow. Or something went wrong uploading the files.

    If you don't want to loose your data, don't change the database and don't delete/overwrite the albums folder. Actually you just need to follow the upgrade instructions on our site. https://www.zenphoto.org/news/installation-and-upgrading

  • After tinkering around with the upgrade for some time with no success, I went ahead and just emptied my database and tried to do a clean install of 1.5.7, the last version I was successfully using before I tried upgrading.

    Now I'm getting a message on the setup page during the install process that says "We do not test upgrades that skip releases. We recommend you upgrade in sequence."

    I don't understand how I could be getting an upgrade error when attempting a totally clean install. I didn't run across this problem the last time I was first installing 1.5.7.

    In any case, the install is hung up and I cannot proceed. Advice?

  • acrylian Administrator, Developer
    edited November 26

    The message is correct since you skipped 1.5.8. There should not be much difference with 1.5.9 actually. I did the upgrade on several standard shared hosts without any problem. All I again can request is the usual "please review the error logs". Meaing ZP's own debuglog and the setuplog and if you can your server's errorlog. Otherwise we are guessing around. If you have any third party themes or plugins remove them for now just in case.

Sign In or Register to comment.