DB access denied

Trying to install Zenphoto 1.9 on my domain #2 and getting the following error
“Access denied for user 'zgjoig6r3l7b'@'localhost' (using password: NO) in /home/zgjoig6r3l7b/public_html/xxxxxxx.com/Photos/zp-core/functions-db-MySQLi.php on line 30”

Domain name was changed in above for privacy purpose.

Had it working with version 1.5 but a GoDaddy malware scan said version 1.5.4 was outdated.

I am using GoDaddy shared hosting. Have 2 domains. Domain #1 upgraded okay. Domain #2 has been giving me trouble.
Things I have tried:
• Deleted DB and recreated it from Cpanel.
• Created DB with a different name as a test

The user listed in the message is not the one I input in the Zenphoto setup screen.

I checked zenphoto.cfg.php and it has the correct DB name & user & PW.

Any help on resolving this problem would be appreciated.

Jim

Comments

  • acrylian Administrator, Developer

    Yes, 1.5. was a bit outdated.

    The user listed in the message is not the one I input in the Zenphoto setup screen.

    Are you sure your are accessing the right install respectively looked at the right config file since you say you have two domains. That would be the only reason the user could not match.

  • Yes I am accessing the correct installation.
    The user it is denying is the Host ID not the Domain DB user.

  • acrylian Administrator, Developer
    edited December 2021

    Sorry, we cannot really help here. This is something your host needs to help with. Probably something is not right with the database credentials user, password or both or else.

    Otherwise try to delete/rename the config file (make copy first in case…) and ry to set the database credentials freshly. There is a template config file within zp-core or just re-run setup to have it re-created.

  • Tried deleting config file multiple times.
    Created a test DB with different user name & db name,
    All with same results

  • acrylian Administrator, Developer

    Sorry, no idea then. The error suggest somehow wrong credentials. If you are really using "Localhost" for the db server make sure this is really correct (on lots of hosts I know this generic name does not work anymore).

    If you are sure that's not it and there are not other erros in any log, please conact your host.

Sign In or Register to comment.