user_login-out.php problem

Hello,

Using Zenphoto 1.5.9. Original zp-core folder.

Colorbox extension is disabled in my admin extension config page.
I do not want to use it !

If I enable user_login-out extension, displaying a full image activates Colorbox.
If I disable user_login-out extension, displaying a full image works as expected (I can click the magnifying glass to display my full size picture)

Editing user_login-out.php file,
I removed line 17

(if (isset($zp_gallery_page) && getOption('user_logout_login_form') > 1) {
setOption('colorbox
' . $zp_gallery->getCurrentTheme() . '' . stripSuffix($_zp_gallery_page), 1, false);
require_once(SERVERPATH . '/' . ZENFOLDER . '/' . PLUGIN_FOLDER . '/colorbox_js.php');
if (!zp_has_filter('theme_head', 'colorbox::css')) {
zp_register_filter('theme_head', 'colorbox::css');
}
})

Then I enable user_login-out extension, displaying a full image works as expected !

I might be alone, as I've got a personal theme (based on the Basic theme).

I know I should never change zp-core files, but as this solves my problem, I keep using my login-out.php file.

Comments

  • acrylian Administrator, Developer
    edited February 14

    The user login_in_out plugin has an option to show the form in a colorbox or directly. If that is enabled it will load the colorbox plugin as that option otherwise will naturally not work.

    Additionally the printUserLogin_out() of the plugin that is used to display the form has a parameter to override that option.

    If you do want the form in a colorbox but not the full image the proper way is to modify your theme and not hack core files. All you need to do is remove the JS code from <head> of the image.php page. I think just removing/renaming the "fullimage" class of the image link would also work.

Sign In or Register to comment.