Can anyone suggest a good ISP to host my zenphoto system.
Ionos (ex 1and1) do not allow setup.php to be executed.

Any advice gratefully received.


  • acrylian Administrator, Developer

    Ionos at least over here in Germany would be a suitable host although I would not pick it. What is the actualy problem with setup? Zenphoto runs on fairly standard hosts.

  • When I run setup.php in a browser I get a 404 File not found error message.

    When I run setup.php in a secure shell I get:-

    /zenphoto/zp-core$ ./setup.php
    ./setup.php: line 1: ?php: No such file or directory
    ./setup.php: line 2: syntax error near unexpected token dirname' ./setup.php: line 2:require_once(dirname(FILE) . '/admin-globals.php');'

    Ionos support say that I need root permissions and this is not allowed on a shared server.

  • acrylian Administrator, Developer

    Can you confirm that you really have installed everything correctly and that these files really exists? Both setup.php and admin-globals.php should be within zp-core. Otherwise re-download and re-install.


    • make sure that you are not using PHP 8 as ZP 1.5.9 is not compatible yet (as noted on the requirements). Use PHP 7.4 instead for now.
    • Review your PHP error log
  • Thanks for your help, but the problem is definitely Ionos!
    I have checked all files exist with correct permissions - same problem.

    I then tried uploading to a different Ionos site, and the Zenphoto installation begins without a problem!

    So, Zenphoto cannot be installed on my Ionos "Pro" contract, but can be installed on my Ionos "1&1 Unlimited Pro" contract.

    Beware also, the Unlimited contract was set up back in 2016, and Ionos may have changed this in the meantime!

  • acrylian Administrator, Developer

    That's really weird… So the newer account does not work but the older does? Please review logs (zp-data for ZP's own, there is a setup.log and a debug.log). There must be some reason for this.

    Btw, just after you reported I got an issue with a Strato webspace (belongs to Ionos/1and1 over here) where the database credentials don't work although they are correct according to their backend. Never had this with any other host…

  • Thanks for your help - in fact the error was entirely mine!!!

    I had placed the zenphoto directory in the wrong place, and in a rush of blood to the head (or wine to the stomach) I wasn't precise enough in my checks when trying to identify the problem.

    This was compounded by Ionos support telling me it was a root permissions problem, but I should have known better.

    Sorry to have wasted your time.



  • acrylian Administrator, Developer

    No problem, such things happen! Good it was easily solved after all.

Sign In or Register to comment.