Closing Zenphoto/Galleries

Dumb question I'm sure.
I am brand new to Zenphoto, have installed it and created an album, on an existing website. The gallery/album is accessed via a hyperlink on a web page (PDF actually), and it is functioning as I expected.
When finished browsing the 50+ photos in the album, I click on 'Gallery' to return to the gallery. My question is - how do I close that page and return to the web page from which Zenphoto was activated?
I can do it by pressing the browser back button 50+ times (well I could if I was a masochist).
If I close the web page, the browser closes.
I have tried setting the hyperlink target frame option to New Window, Same Frame, Parent Frame, etc, but the result is always the same.
I have searched the Forum and the User Guide - which is more a programmers guide than a 'user' guide - to no avail.
All help and suggestions appreciated.

Comments

  • acrylian Administrator, Developer

    My question is - how do I close that page and return to the web page from which Zenphoto was activated?

    I can do it by pressing the browser back button 50+ times (well I could if I was a masochist).

    The browser back button (= the browser history) is the only way to do that because Zenphoto does not know where you came from. That has nothing to do with Zenphoto actually but is how the web works.

    If you really need this: The only way would be to do quite some rather advanced custom coding. Your PDF links would have to contain a $_GET query like e.g. ?source=sitepdf and then you would have to create a custom breadcrumb to check for that to make - this gets really complicated if you also have several pages of images or even subalbums as that needs to be present everywhere otherwise you break of course direct visits - the current page close on the clicking "gallery" and redirect somewhere else. Closing a browser window and redirecting would have to be done via Javascript.

    If you only understood half of that, I suggest to just live with it ;-)

  • OzFoxy Member

    Thanks for your guidance. You steered me in the right direction and caused me to look more closely at the Admin settings.
    I solved the problem by putting the hyperlink on my home page and opening the gallery in a new (blank) page.
    Now the browser back button, or closing the page, takes me back to my home page.
    Many thanks

  • acrylian Administrator, Developer

    Thanks for the follow up. Glad you figured out something simple that works for your!

Sign In or Register to comment.