1.6.a install problem

Hello,

Installing 1.6.a from scratch gives an error on my localhost machine :

Parse error: syntax error, unexpected 'version' (T_STRING) in /16a/index.php on line 37.

16a is the folder that contains Zenphoto 1.6.a.

Here is line 37 :
?><?xml version="1.0" encoding="utf-8"?>

Do we need php 8 to run it (currently using php 7.4)

Comments

  • acrylian Administrator, Developer

    No, 1.6a should run on PHP 7+ and does for me actually.

    ?><?xml version="1.0" encoding="utf-8"?>

    I can only assum that the <?or more specifically the closing ?> are mistaken for PHP closing tags. Does your server have PHP short tags (<?) enabled?

  • ctdlg Member
    edited May 3

    Yes,
    short_open_tag On
    info given in phpinfo.php page.
    Using PHP7.4.27 under archlinux, Xampp on my localhost computer.
    I did replace
    <? with <?php Same error. If I set short_open_tag to off, I get that blank page : http://fila4/16a/zp-core/setup/index.php?autorun=gallery ... I tried ?><?php echo '<?xml version="1.0" encoding="utf-8"?>';?>

    Same blank page.

    Console shows this error :
    Cette page est en mode de compatibilité (quirks). La mise en page peut en être affectée. Pour le mode standard, utilisez « <!DOCTYPE html>

  • acrylian Administrator, Developer

    Sorry, don't understand it, that is the standard RSS placeholder and is not used unless RSS is requested…

    Do you have any placeholder files within /plugins/site_upgrade/? If so you should not even reach that line…

  • acrylian Administrator, Developer

    Another thing to look at: Is your config file correct? THe way of loading it has changed as well. Formerly it was read as a text file and then eval'ed, now directly via require_once since it is of course already a PHP file.

  • ctdlg Member
    edited May 3

    1 I download your Zenphoto zip file
    2 I decompress it on a localhost folder
    3 I enter this folder
    4 I get the above error, line 37, index.php file.

    5 I tried editing your index.php file : error or blank page, Firefox console gives some information (above) (written in French)
    Translation :
    Diese Seite befindet sich im Kompatibilitätsmodus (Macken). Das Layout kann beeinträchtigt werden. Verwenden Sie für den Standardmodus "<!DOCTYPE html>

    You could try a new install from scratch as I did !

  • acrylian Administrator, Developer

    Thanks for the translation, I did understand your Firefox is somehow in Quirks mode. Still don't get why.

    Is you config file created correctly btw or don't you get that far at all?

    I will try a fresh install for sure later on.

  • ctdlg Member

    You cannot open any page ! (error with root index.php file.)
    config file can only be created if you can display 1st admin page.

  • acrylian Administrator, Developer

    You can of course also manually create the config file by using the template from zp-core. But we can reproduce some issues with a fresh install and try to solve it. There is a reason this is alpha status ;-)

  • ctdlg Member

    I understand the alpha status, of course.

    I did try on my online website.
    Same problem.

    I do not need to install 1.6.a, I just want to help a little.
    This is why I tried from scratch.

  • acrylian Administrator, Developer

    Of course and I appreciate the tests and help!

Sign In or Register to comment.