Gallery blank, could be PHP upgrade?


My ZenPhoto install has just disappeared and the page is blank. I did manage to get into the /zp-core/admin.php but now it just seems to be hanging. My host is DreamHost. I see I'm on PHP 7.4

@Acrylian, is there anyway I could hire you to get the install working again? It's mostly a legacy site of fashion week images, but I am trying to add to it regularly again and would love to have it working.




  • Just to clarify my bad articulating above. The install is still all on the server etc. It's just not showing anything when you go to the gallery.

    Trying to load the backend I get: 504 Gateway Timeout (whatever that means).

  • acrylian Administrator, Developer

    Please review the debuglog and if you can the PHP error log of the server. Also please post the Zenphoto version.
    If you cannot access both via the install itself you can directly via FTP. The log is within /zp-data and the version in /zp-core/version.php

    is there anyway I could hire you to get the install working again?

    Theoretically yes but if you are not in Germany it may be a bit complicate sadly. Please contact me directly, see

  • Thank you for the speedy reply.

    I will FTP in now and take a look.

    If payment is an issue, I can get my sister in Dusseldorf to pay you?

  • acrylian Administrator, Developer

    No payment is not the issue, bureaucratic things are respectively may… More on that if you contact me directly.

  • Okay, I've just FTP'd in using FileZilla.

    in /zp-data there is a bunch of debug.log files, going to debug-10.log but I see the last dates on them were in 2017?

    And there is no version.php file in the folder.

    Not sure what to do?

  • acrylian Administrator, Developer

    No, look at the debug.log one without number. For some reason we just number the archived older ones (will put it on the list to use a date string instead).

  • Thanks - managed to pull it and it's a huge file. The last updates were in 2017 to it.

    Still trying to see what version I have of the install as there's no version.php

  • Managed to get into the admin page and got the following:

    Zenphoto version 1.5.7 (Official build)
    Server software: Apache
    PHP version: 7.4.15
    PHP memory limit: 500M (Note: Your server might allocate less!)
    MySQLi version: 8.0.28

    So I chose to re-install and the Mod_rewrite check was in red at the end. Is this a potential issue?

  • acrylian Administrator, Developer

    That sounds as if all is so far as if everything should work. 1.5.7 ist a bit older already though (well 1.5.9 is from last year, too).

    Still trying to see what version I have of the install as there's no version.php

    There must be one within /zp-core.

    I doubt that modrewrite is the reason as the homepage at least should work. Furthermore the modrewrite check not always 100% reliable as there is no exact way to check it.

    If there is really no error that is unfortunate. What theme are you using?

  • acrylian Administrator, Developer

    And/or any third party plugins used?

  • Thanks Acrylian.

    Plug-ins are only standard installed ones.
    Theme is just a modified (basic changes, as in logo and colours) ZenPage.

    How do I update to 1.5.9? Not really sure, and would it affect the albums + database?


  • 22 active plugins:
    keyboardnav-extended v1.0.1

  • acrylian Administrator, Developer

    iOS is for sure not an official plugin, so might (or might not) be a reason for trouble. It should be in the /plugins/. To disable it without backend access, just remove it from there (it might be a php file and a folder of the same name).

    Depending when you made the changes to the Zenpage theme it of course might be missing a change. However since the install has not been updated since 1.5.7. the sudden problem is rather not related to that itself.

    You find the update instructions here:
    It's a bit technical, sorry.

  • acrylian Administrator, Developer

    Not really sure, and would it affect the albums + database?

    No, it "should" not but a (database) backup is always recommended. For the database there is an included tool.

  • Thanks, I'll get onto this right away and delete the iOS folder. I think I tried putting that in there about 10 years ago. haha.

  • acrylian Administrator, Developer

    That still exists but last update seems to be 5 years ago.

    It might or might not cause trouble.

  • acrylian Administrator, Developer

    Another obvious thing you can test taht cause blank page is the file and folder permissions:

    These do not cause log entries. These things can (although should not) happen if the host does some updates or internal migrations on servers.

  • Checking this now, have deleted and disabled iOS.

  • So I took time to try the following:

    • all permissions
    • changed the theme to the basic one
    • database check

    And still just have a generated blank file (with nothing in it) for the site page.

  • acrylian Administrator, Developer

    I have checked the domain you mailed me and it returns a 404 error. That suggests something is really not right…

    Can you confirm that all files as noted on the section on are present?

  • I can access the back-end and host says everything is fine. Host is Dreamhost. I'm so confused, it's like it just went blank overnight.

    Going to try the upgrade route this weekend when I get a gap. Thanks and I'll report back. REALLY do appreciate your assistance. Thank you.

  • acrylian Administrator, Developer

    Really weird as that normally does not happen just randomly. But without proper errors it hard to narrow down.

    Before you try the direct upgrade you could also try a plain re-upload of the 1.5.7 files first. Just in case just a file got broken for whatever reason…

  • SimonD Member
    edited September 2022

    Sorry for the long silence, real work got in the way!

    So I finally tried to upgrade to 1.5.9 and followed the steps linked above, and it now displays the "site is undergoing an upgrade" page.

    However, it still does this even if I go to /zp-core/setup.php or /zp-core/admin.php so no idea how to actually get around this now.

    Any assistance would be appreciated. :)

    EDIT: I may be the stupidest person here. I dont think I even actually uploaded the /zp-core/ folder. Doing it now. :( I'm really not a tech person! LOL

  • acrylian Administrator, Developer

    Sorry for the long silence, real work got in the way!

    No problem, does here constantly as well (and life, too ;-))

    Did you login with your admin rights account before doing the upgrade?

    You try to disable the maintenance mode by editing the config file $conf['site_upgrade_state'] and set it to "open". Then you should be able to run setup which must happen in any case.
    If that alone does not work, remove the config file (keep your data to re-fill in).

  • Thanks acrylian.

    But purely down to my lack of skills and being stupid. As soon as I finished uploading the /zp-core/ folder for 1.5.9 I could run the setup and within minutes the site is back to normal. Total time to do: under 15min.

    Thank you once again, it's really appreciated.

  • acrylian Administrator, Developer

    Great you managed it. That's how it should work actually!

Sign In or Register to comment.