Zenphoto and PHP 8+

Does or will ZenPhoto run on PHP8+? So I had a version running on PHP 7.4 and recently upgraded to 8.1 and it now does not work.
So is there an upgrade to Zenphoto coming soon?

Thanks for any help,

yamiacaveman

Comments

  • acrylian Administrator, Developer

    The current Zenphoto 1.5.9 is not PHP 8 compatible which is noted. And yes there is an update in the works.

  • Thanks for your response.

  • Is there already a (rough) ETA in sight for the PHP8 version?

  • acrylian Administrator, Developer

    Probably around mid november

  • Great, thanks a lot!

  • pled Member

    Excellent news ! My provider is stopping PHP7 by the end of November, and provides me with that info page to explain they cannot delay anymore :
    https://www.php.net/supported-versions.php
    So 28th of November is the stop date... Cannot argue against that ! ;-)

  • Is it "mid november" yet? I hope you didn't mean November 2023 ... (-:

  • acrylian Administrator, Developer
    edited December 2

    Well, sorry, we clearly didn't manage it. Some bugs related to PHP 8.1 were found that needed to be fix first. Combine that with ZP being not the main job… But according to the docs we should actually even be settled for PHP 8.2 coming this month.

    You can try the master from GitHub aka 1.6RC:
    https://github.com/zenphoto/zenphoto/archive/refs/heads/master.zip

  • @acrylian Of course, you realize, I was poking fun and not criticizing. We've all been there ...

  • acrylian Administrator, Developer

    Sure, no offense, I understood that smiley ;-) Just wanted to explain also for other that read here only. I wish we could have been faster and I can feel that it is not nice to wait if a site depends on that. Gladly only a few hosts seems to really switch of right away (our own does not).

Sign In or Register to comment.