Site works on back-end, but front end is 500 error

david1pro Member
edited October 23 in General support

Hi, After a month of setting up my site, I moved it from my NAS to my host (Dreamhost). I did the method described for moving a site. I ran the setup and am able to do anything I want on the back end. Everything seems to be there. I can upload files via the backend as well. However, the front page of my site shows a HTTP 500 server error. I have played with the zenphoto_cfg.txt file. I have changed "strict" to "relaxed" in setup and I have run setup multiple times. I have turned mod-rewrite on and off as well. The site is set to open.

I have noticed that on the overview page, the server path seems correct but the "web path" entry below that is blank. The problem persists when I switch to one of the default themes as well. PHP version: 7.4.28. I also commented out the line IndexIgnore * on the .htaccess files.

I can't figure it out. Any ideas?

Thanks in advance for any help.

Comments

  • david1pro Member
    edited October 23

    Disabling the "Favorites" plugin has solved this issue, however, that means I need to figure out why that is happening... the error in my logs that clued me into this was (~~~ with some redacting):

    [fcgid:warn] [~] [client ~] mod_fcgid: stderr: PHP Fatal error: MySQLi Error: ( SELECT aux FROM [prefix]plugin_storage WHERE type="favorites" AND aux REGEXP '[[:<:]]David[[:>:]]' ) failed. MySQLi returned the error Illegal argument to a regular expression. in /home/~~~/(mysite).net/zp-core/functions-db-MySQLi.php on line 95, referer: https://(mysite).net/

    I can say that with the plugin enabled, the page does not fail until I log in (IE, incognito mode loads the page until I log in). This still happens even on the zenpage default theme, which I have never altered, so I would say this is a plugin issue, and not something I did to the them.

    Thoughts?

  • acrylian Administrator, Developer
    edited October 23

    but the "web path" entry below that is blank.

    If you install a site within the root of a domain the webpath must be blank because technically it is not installed in a folder even if the domain points to one on the webspace.

    The htaccess should therefore have just this (which is the "webpath" basically):

    RewriteBase /

    You should not need to change the htaccess file. Be sure you have modrewrite enabled on the options. Otherwise rewritten urls on the front end very well may cause 500 errors and such. Setup does check for modrewrite but there is not 100% reliable check for doing that - you cannot just call a function to see that - just sort of workarounds.

    To your mysql other issue I cannot tell anything right now. Are you sure the databases have the same encoding and such? Did you really follow the exact order albums folder first then db on moving? Also please review the debug log.

  • I had also noticed that my tags weren't working, so I figured that might be a database issue (the "tag cloud" was correct, but clicking a link would bring no results, while searches of everything that wasn't a tag did bring results), so I did a fresh install. That solved the tags issue. However, the favorites handler plugin still causes the front end to throw the error, so to keep things logical, I'll start a new thread just for that issue, as everything else is working, and favorites don't work site wide (after selecting your first favorite - the issue is immediate), no matter the theme you are using.

  • acrylian Administrator, Developer

    Just to note, I cannot reproduce the issue on my local test install. I am testing with 1.6a of course but I don't recall any change in this area.

  • Interesting. I was excited about favorites as it works fine on my site running on my NAS, and I figured my family members would appreciate the feature. I'm not smart enough to fully investigate this; maybe it's something with DreamHost. Maybe it'll work on DreamHost with the impending upgrade to 1.6x.

  • acrylian Administrator, Developer

    Maybe it'll work on DreamHost with the impending upgrade to 1.6x.

    If you can try 1.6a that on a separate test subdomain - do not use it on an important site yet - for example would surely help us to not ship an unnoticed bug here.

Sign In or Register to comment.