Zenphoto 1.6rc testing :

I did a fresh installation without problem on a subdirectory of my online website : no problem; restoring database with the Zenphoto tool did work.
I'm already using zenphoto 1.6a - Good to know 1.6rc will work !

I could not install it on my localhost machine. Database info was rejected.
I will completely uninstall files from my computer, reinstall xampp with php 8.1 and retry zenphoto 1.6rc.


  • ctdlg Member
    edited November 2022

    New Xampp install with php 8.1
    My localhost (zenphoto1.6a) copy does work.

    Still unable to install 1.6rc from scratch : sql error.
    on page

    I do not use a sql password on my localhost machine.

    user is root
    password is empty ( I do empty it - see screenshot below showing a password that I remove...)

    Could this be the problem with 1.6rc ?

    1.6a on same localhost machine :
    I use
    user root
    password empty
    Again it does work !

  • ctdlg Member
    edited November 2022

    localhost problem solved.

    mysqli NEEDS a password with zenphoto 1.6rc

    msqli do not need any password with zenphoto 1.6a or less !

    help to change the sql password :

    Conclusion : install ok for me, both online or on localhost.

    I will now upgrade my existing 1.6a localhost ... (my online backup)
    If ok, I will upgrade my online website.

  • acrylian Administrator, Developer
    edited November 2022

    Yes, you have to provide a password. Mysql itself does no work without a password. Zenphoto never set a "default" for this but older PHP may have used some server default like root (which is the user and pw on my local server). You cannot leave it empty as especially on PHP 8/8.1 both handlers would fail with kind of fatal error if one of these core info is missing.

    But thanks for testing!

  • Xampp installs mysql without any password, and did work without any password.
    1.6a and previous versions did not request a password.

    As mentioned, I have added a password using phpmyadmin, 1.6rc does work with it.

    I have upgraded my localhost website to 1.6rc.
    I'm currently testing it (php 8.1).

    If everything is OK, I will upgrade my online website from 1.6a to 1.6rc.
    And move from php 7 to 8 ...

    Thank you for your help.

  • acrylian Administrator, Developer

    Yes, of course, I was just explaining it in case others stumble upon it.

  • I upgraded my online website from php 7.4 to php 8.1

    I've upgraded my online website from 1.6a to 1.6rc.

    I could not succeed reinstalling, and had to ignore - problem was my database
    I changed it's "interclassement" (from latin1 to utf8mb4)
    then I succeeded reinstalling it.
    The zenphoto database restore tool does work !

    I have checked my online website : nothing loosed.
    Everything seems Ok.

    I will report if I find something weird.

    Thanks again.

  • acrylian Administrator, Developer

    I could not succeed reinstalling, and had to ignore - problem was my database

    I changed it's "interclassement" (from latin1 to utf8mb4)

    That encoding change is not really a requirement, more a recommendation (as it always already was). A plain conversion from non-utf8 to any utf8 may have side effect which is why we don't do that.

    But glad that all else so far worked as expected!

  • tplowe56 Member
    edited December 2022

    I have the same or similar issue on my localhost. Tried for 8 hours. Everytime I do fresh install of 1.6rc my xampp installation spits out this error and I am unable to access myphpadmin until I reinstall Xampp (W10) or apply other workarounds to regain access.

    Error: mysqli::real_connect(): (HY000/4151): Access denied, this account is locked

    Tried dozens of solutions, concerning the mysqli password, nothing works. I see this error mentioned hundreds of times, but no solution I have tried has worked.Xampp and PHP seem fine, but the attempted installation of the database, seems to cause problems.

  • Finally got installed correctly. Very finicky process, but with trial and error I got it.

  • acrylian Administrator, Developer

    Then please tell what you did or needed to do. PHP 8/8.1 is a bit m more strict than PHP 7 and earlier and that also counts for mysql credentials.

    Because we tried numerous fresh installs on our localhost using MAMP and at least two live servers (plus others did as well).

  • tplowe56 Member
    edited December 2022

    I think it was the order in which I did the install. This is all local, which is sometimes harder than on a live server.

    I did a fresh install of xampp, which included 8.1.

    Then I created a database in PHP with exact name as my current DB, (in old install). Gave the DB user/root, a password.

    Then installed ZP-1.6 rc (fresh not an upgrade). Using the DB name, user, and a password set in PHP.

    Then used ZP to restore my gallery db from a backed up DB.

    I think an upgrade install of 1.6rc may go a lot smoother. I'll report back on my live server install.

  • acrylian Administrator, Developer

    That sounds a bit too complicated to be right… I remember that I talked with someone (or was that even you?) that on localhost it worked not to set either name or password since it is usually root by default. This for sure does not work anymore. All mysql credentials must be setup, otherwise it will not work. We cover this because under 8.1 it will break with a error otherwise anyway. Perhaps it is that only…

  • tplowe56 Member
    edited December 2022

    Yes, I had a similar problem in the past years ago, with a fresh ZP install on Xampp. My search on the internet yielded a lot of posts about recent problems with SQLi needing a password for 'root', which seemed to be my issue, as I kept getting locked out after the ZP 1.6rc install (due to the DB, with or without a password).

    Local ZP 'upgrades" have always gone smoothly since they do not require a new DB.

    I think the sequence that made a difference was creating a DB, and giving root a password BEFORE installing ZP, and then using that DB for ZP. (Maybe that is the correct sequence anyway.)

    All good now.

Sign In or Register to comment.