password reset link

Normandiai Member
edited November 19 in General support

Hello!

I've been looking for it, but I haven't found an answer to my problem. My problem is with the password reset. When I request a password reset link as a user via email, it is always sent. But it sends it to the wrong address. Because not to the email address specified in the user profile, but to the admin email address.
So I can't automate the lost password replacement, because every time a user must wait for a new password to be manually obtained and sent to him/her in a separate email.
How can I change it so that the users password reset link is not sent to the admin email address but to the users personal email address?
Sorry for the linguistic mistakes!
1.5.9 (Official build)

Comments

  • The request is always sent to the admin. That is incase the user email address either does not exist or is incorrect. Then the admin can take steps to rectify the situation.

    The request will also be sent to the user's email address of record if there is one. So if your user is not getting the request he either does not have an email address or the one on record is not correct.

  • Hello,

    My visitors could not receive emails because of static_html_cache extension.
    If your user email is correct, also check (disable) this extension.

  • acrylian Administrator, Developer
    edited November 21

    My visitors could not receive emails because of static_html_cache extension.
    If your user email is correct, also check (disable) this extension.

    I don't think, the form with the reset link should be backend which is not cached at all. And the fix for the contact form is - as mentioned already - not to disable the cache but to exclude the page using the contact form via the contact_form plugin's options. Its standard option has the standard contact page already excluded but of course if you use another page you have to modify that.

  • Hello!

    Thanks for the help, I found the cause of the error. The mail was incomplete because it had no sender. I am using the PHPMailer plugin, which was filled out, but in the Name and Email line in the general tab, only the name was given. I thought I shouldn't have to enter the email address separately there if it was set up in the plugin. I was mistaken, although it is clearly written: This email name and address will be used as the From address for all mails sent by Zenphoto. When filled in, it works like a dream.
    Thanks again for your help!

Sign In or Register to comment.