Characters inserted into database upon saving

I am finding these characters inserted into the database when ever I save a change to an image on the back end. The number 28 refers to the # of characters between the double quotes. Shows only in my database. It does not display on front or back end of ZP. If I edit the row and save in PhpMyAdmin all is fine unless I edit the back end for this image, then the characters will reappear. I also see this happening in other areas of the database. I noticed them written into the zp_plugin_storage table. Must be a setting or configuration on my PhpMyAdmin. It does not occur on local server. Must be something to do with the character set.

Anyone have any ideas what is causing this

a:1:{s:5:"en_US";s:28:"Kenya - Hot Air Balloon Ride";}

It should be like this 'Kenya - Hot Air Balloon Ride'

MySql vers. is 5.6.51


  • acrylian Administrator, Developer

    No that is correct and as a long time user you should actually know about that. Please see here:

  • Sorry, I have never used the multi-lingual option so there was no need for me to educate myself in this area.

    I do not have multi-lingual selected on my local or live site. This does not occur on my local server and no multilingual references are contained in the database.

    But it it does occur on my live server and multi-lingual is not selected.

  • acrylian Administrator, Developer
    edited January 14

    Please read again:

    Note: The contents of each language still share the same database field (e.g. title or description) but it is divided and technicall stored as a serialized string. So don't be confused if you see strings like {s:5:"en_US";s:9:"album title";} in your database. Zenphoto stores those contents that way even if you never used the multilingual mode to avoid data loss on enabling/disabling.

    Some string may be without that seriliazied on some occasions but on the next saving on the backend it will be added regardless. So nothing to worry or fix.

  • Ok thanks, everything good.

Sign In or Register to comment.