Upgrade gone wrong

I want to start off by saying that I know nothing about anything about website building or whatever skillset that is required to set up ZenPhoto.

I decided this week to try to upgrade the version I was running. I think what I was running was something in the 1.4 range. I did this because, the photos in the gallery that aren't the high res files having degraded in quality since last time I uploaded anything, and its making the photos I post on my website look really low quality (I'm not sure I even described this correctly.)

I have tried multiple times to upgrade to the newest version, per the instructions on the installation and upgrade guide, but I can't run set up because I get a configuration error message whenever I try to visit any url in my Zenphoto galleries. The issue actually began as my not being able to get the site out of upgrade mode because when I tried to do that, it was not in the plugins list like in the version I had been running. Not even sure how I progressed to the point of getting configuration errors.

I have looked for the config file, after doing searches on the forum as to how to possibly fix this, but I can't find it. i read on here that the database permissions may need to be changed in that file.

I'm sorry to be asking for help when I don't even know what most of this stuff means, but I've had Zenphoto installed on my site since 2009 and have thousands of photos in my galleries. Any help would be appreciated.


  • acrylian Administrator, Developer
    edited March 18

    I think we talked on a social media channel already about this.

    A configuration error means generally the config file is not setup correctly especially the database credentials or for some reason is missing completely.

    Since you upgraded I am not sure how that could happen unless you overwrote it on the upgrade accidentally (see what files and folders you need to upgrade here https://www.zenphoto.org/news/installation-and-upgrading/). If you were running Zenphoto 1.4.something upgrades should generally work. I did plenty of these myself without any issue (despite necessary compatibility changes on custom themes).

    The upgrade mode can be disabled from the backend - there is a notice visible.

    Access your site via FTP on the webspace and review the data within the config file found on:


    Make sure the database credentials are correct. If it is missing, copy the file from

    /zp-core/file-templates/zenphoto_cfg.txt to zp-data and rename it to zenphoto.cfg.php. Then fill in the database credentials.

    As long as these are not correct the config error will of course not go away and it makes no sense to disable the upgrade mode.

    If they are correct you can disable the debug mode from the backend. If you cannot access that you can disable it via the config file.

    Find an entry like $conf['site_upgrade_state'] = "open";
    If it doesn' have "open" change it to that.

    If all does not help review the file debug.log in the same folder for errors to see

    Regarding the possible image quality problem please open a separate topic. This is about the config issue. Always one issue per topic please.

  • araney Member

    Thank you so much. I finally realized what happened was that I had to change my database password in the midst of all of this, and that wasn't reflected in the config file. I was able to edit that, and now I can access my galleries again. Thanks ago!

  • acrylian Administrator, Developer

    Great! Always good if it is just a simple thing even if these may often be hardest to catch.

Sign In or Register to comment.