jPlayer not working on ZenPhoto 1.6 / Rocky Linux / Apache setup

Hello! I am a new Zenphoto user / admin, looking to migrate away from Piwigo to a platform that offers better video support. I have a Rocky Linux server set up using Virtualmin, which handles Apache and other aspects of the server. I was able to download and install Zenphoto easily, get my photos organized and online, and begin customizing everything. So far, so good.

The one big challenge I've run into so far is that my MP4 videos aren't playing. They come up on the album as ".mp4" thumbnails, but when I click on the Play icon, nothing happens. The videos are valid MP4 files - I'm able to view / play them on my Mac without issue using the built-in viewer.

The issue can be seen at:

When I look in Firefox, I see the following message:

Media resource could not be decoded, error: Error Code: NS_ERROR_DOM_MEDIA_DEMUXER_ERR (0x806e000c)
Details: virtual RefPtr mozilla::MP4Demuxer::Init(): No MP4 audio () or video () tracks FMA-ArmMount_20220929100115.mp4

I suspect that I may be missing a package or similar on my Host, but didn't see anything when I did a Google search for this issue.

Thank you for any help and guidance!



  • GJSchaller Member
    edited September 2023

    Apparently it was the video format... I ran it through a converter and it works now. Odd that the original output was MP4 and it didn't work, but I'll work with it.

  • acrylian Administrator, Developer
    edited September 2023

    .mp4 is a container, important is the codec used and that even can be separate for video and audio. Not all browser can play everything.

    Btw, you don't need jPlayer at all, the 3rd party script is not developed by its devs anymore and the plugin is marked as deprecated. The class-video plugin offers native video/audio support.

Sign In or Register to comment.