Admin only showing first 10 galleries

I just installed 1.6.1. It was a fresh install. I then copied the albums directory over from a 1.3 installation. Everything seemed fine until I went to the admin page to password protect one gallery. The admin section only shows the first 10 galleries and there's no way to edit the others.There's no next or previous button. I've tried reloading the page, I've tried in Chrome, Firefox, and Safari (I'm on a Mac) and still only the 1st 10 galleries appear in the admin section (everything looks fine on the publicly available site). I've tried creating a new gallery and while it creates the directory, it doesn't show up in the admin section either.
What can I do to show all the galleries in the admin section?



  • acrylian Administrator, Developer

    First the right term to avoid confusion is "albums". "Gallery" traditionally refers to the site in total in Zenphoto terms.

    This can be various things like PHP issues but if a user with full admin rights does not see all albums there might be a file/folder permission issue. Please review your logs.

  • The only PHP errors I see in the logs are for another part of the site.

    The debug.log in zp-data has this repeated a few times:

    {2612002:Sun, 18 Feb 2024 03:28:02 GMT}
    WARNING: imagecreatefrompng(): gd-png: libpng warning: iCCP: known incorrect sRGB profile in /var/www/html/xx/xx/xx/zenphoto-1.6.1/zp-core/classes/class-graphicsgd.php on line 59
    imagecreatefrompng called from graphicsGD->imageGet (class-graphicsgd.php [59])
    from TextObject->getThumbDimensions (class-textobject_core.php [195])
    from Image->getThumbWidth (class-image.php [701])
    from Image->getOrientation (class-image.php [734])
    from Image->isSquare (class-image.php [769])
    from getAdminThumb (admin-functions.php [4769])
    from getAdminThumbHTML (admin-functions.php [4810])
    from printAdminThumb (admin-functions.php [4837])
    from admin-edit.php [1022]

    However there are not enough of these entries to match the number of times I reloaded the site. So I'm not sure this is related to the problem.

    I did narrow it down to an empty directory called Import-1. removing that directory and the admin section loaded correctly. Permissions on that directory were 755 same as all the others in the ablums directory. So not a clue why it got stuck on that one unless it is a reserved word or something for zenphoto.

  • acrylian Administrator, Developer

    Really weird, "import-1" is surely no a reservered word in ZP. And even empty albums should show. Sorry, really have no idea.

    The notice you got is not really critical and shsould not be thte reason of albums not showing. But thtey may be changing because by default albums pick their album thumb randomly unless you set a specific one or another options

Sign In or Register to comment.