database / utf-8 problem when updating from 1.5.9

i'm having troubles when updating to the latest release of zenphoto (already tried 1.6.1 and 1.6.2 as well). the update process starts as normal, but then it just hangs at

"Begin converting UTF-8 tables to utf8mb4 collation"

i already checked my database and updated the collation to utf8mb4 via adminer, but it still tries nonetheless.
in the setup-log there is nothing suspicious, and in the debug-log it states:

WARNING: fileperms(): stat failed for /path/to/zenphoto/html/cache/photos/themes_images_imageDefault_w300_cw300_ch200_thumb.png in /path/to/zenphoto/html/zp-core/setup/class-setup.php on line 611
fileperms called from setup::folderPermissions (class-setup.php [611])
from setup::folderPermissions (class-setup.php [602])
from setup_permissions_changer.php [18] 
ERROR: Call to undefined method PDOStatement::getMessage() in /path/to/zenphoto/html/zp-core/classes/class-dbpdo_mysql.php on line 175 

which just says:

171          * Returns the text of the error message from previous operation
172          */
173         function getError() {
174                 if (is_object($this->last_result)) {
175                         return $this->last_result->getMessage();
176                 } else {
177                         return sprintf(gettext('%s not connected'), DATABASE_SOFTWARE);
178                 }
179         }

so this also doesn't help much, i'm afraid. any idea what could be the problem?


  • acrylian Administrator, Developer

    First error is about wrong file/folder permissions.

    Second error refers to the PDO database handler which you apparently have chosen but seems not to be properly available on your server. Try MySQLi instead.

  • i'll check the permissions, i just assumed as it is only a warning, it shouldn't be a serious problem - but i'll look into it.

    cocnerning the PDO database handler, this i used for quite some while now, only thing that changed is that it was updated to a more recent version:

    Your database software has changed from PDO::MySQL 5.5.5 to PDO_MySQL 10.6.17.

    is this a problem? should i switch to MySQLi instead?

  • just a quick heads up - it was a problem with the database handler, just changed it to MySQLi in the config file and everything works like a breeze. thanks a lot!

  • acrylian Administrator, Developer

    'll check the permissions, i just assumed as it is only a warning, it shouldn't be a serious problem - but i'll look into it.

    Yes, that itself is a warning but a general permission issue can lead to other issues, too. The whole albums part of Zenphoto is file system based.

    Regarding PDO there seems something not right. Can't see what it is as we of course tested this. 5.5.5 to 10.6.17 is a huge version jump.
    In any case try MySQLi. For the usages it basically does not matter which you use. But if that also fails something else might be wrong.

  • acrylian Administrator, Developer

    Ah, "cross posting" ;-) Great, it worked out. Still wonder why PDO didn't work for you if it is available.

Sign In or Register to comment.