Backup Fails


I have a new install but the backup fails... I have a backup folder in the root of the zenphoto folder with perms 755 but it still fails...

I ran setup again to see if it would fix things but I still have the same issue...

Can anyone help me?



  • It would help if you provided more details. Specially review your logs including the server CGI error logs.
  • Sorry yes....

    Here we go.....

    {Wed, 07 Nov 2012 20:20:50 GMT} Zenphoto v1.4.3.4[10988]

    Backtrace: WARNING: fopen(/var/www/zenphoto/backup/backup-2012_11_07-20_20_50.zdb): failed to open stream: Permission denied in /var/www/zenphoto/zp-core/utilities/backup_restore.php on line 166

    fopen called

    from backup_restore.php [166]

    {Wed, 07 Nov 2012 20:20:50 GMT}

    Backtrace: NOTICE: Undefined variable: writeresult in /var/www/zenphoto/zp-core/utilities/backup_restore.php on line 211

    {Wed, 07 Nov 2012 20:20:50 GMT}

    Backtrace: NOTICE: Undefined variable: msg in /var/www/zenphoto/zp-core/utilities/backup_restore.php on line 230


    I have checked the perms of the folder and file in question.

    The folder is 755 the backup restore file within is 644...

    Hope this helps?

  • The first error is the problem. Your server is denying Zenphoto the right to create the backup file. permissions of 0755 means that the owner can read/write/execute, but group members can only read/execute the folder.

    So I would assume that your server does not configure the PHP application as the owner of the folder. You can try folder permissions of 0775 in the hopes that the PHP application is at least in the same group as the owner. Otherwise you will need 0777 for the permissions--not normally a recommended setting.
  • Shame...

    Both the Utilities and backup folder where both 775. I changed them both to 777 with the same result...?

  • Then it may be some other security option on the server. All I can tell you is that you are getting a security (permission denied) error trying to create the backup file. At least this is according to what is recorded in your logs.
Sign In or Register to comment.