test drive - mod rewrite

Hi guys, I'm testing driving ZenPhoto for the first time and I thought I'd post this in case anyone else was having trouble. The installation was smooth except for the fact that thumbnails didn't appear when adding a test album.

As the forums describe, this is a mod_rewrite issue, so I activated it in apache and even adjusted the AllowOverride (an Ubuntu issue with it being set to None)..

I ran a bunch of checks to make sure mod_rewrite was on and it was, test php pages were even rewriting properly but ZenPhoto was not and the admin page with the checkbox was grayed out not detecting it correctly.

I thus tried wiping out ZP and reinstalling it again and at that point I was able to enable this feature in the admin section.

I checked the .htaccess file and the rewrite base has not changed from when it wasn't working, so I'm not quite sure what a reinstall did differently.

In any case, as a last resort, if you've tried everything to get mod_rewrite to work and everything looks green, reinstall ZP.

I'm on Ubuntu Server 12.04.1 LTS.
Sign In or Register to comment.