seo_locale problem

I have multi languages set up and they work fine.

The thing is that it doesn't show in the url

For example the link will be zen/en/ but on the browser bar it will revert to zen/
The correct language still comes up but the displayed url is not the same as the link
Is this how it is supposed to be?


  • is English your site's default language? For search engine reasons, the links for the default language will not have any language prefix attached.
  • I have english and slovak

    and default is HTTP_Accept_language

    The languages come up fine but the url is redirected so there is no language prefix.

    How can this help search engines if there is no prefix and the 2 language versions are redirected to the same url?

    Even with english as default language the url is still redirected. Surely this will be bad for search engines
  • Also i enabled the plugin sitemap-extended and when i make the sitemap it doesn't display the separate language pages at all
  • If not otherwise specified, English is the default language of a Zenphoto site.

    if you have a link `mydomain/en/album` and one `mydomain/album` the search optimizers will consider that they are multiple links to the same item and will not index them. Since th latter link is always present, we supress the former.

    Would you like us to generate a 404 error if someone links using the `en` prefix? If so please submit a feature request issue. As to the redirection--that is how this feature works, there is no page with the language in it, so redirection is the only way to get the page to display.

    Is your site `multi-lingual` option set? If not sitemap does not know to create multiple links for each language.
  • Hi

    Thanks for you reply. I thought maybe it would be possible to have mydomain/en/album and mydomain/sk/album.
    If it will be just mydomain/album then how can google know that there are 2 seperate pages like one for english and one for slovak?

    My site has multi-lingual option on. How should the sitemap display the pages? for example will it show them just as mydomain/en/album and mydomain/sk/album or just mydomain/album?
    If the url is the same for both versions of languages then i cant' see how google can know there are 2 different versions.

    Also if the sitemap does show both version of languages but they redirect to the same domain would that not be a problem for google?
  • Also i have tryed everything I can to create the sitemap with multiple links for each language and still no joy. Am i missing something here?
  • The only way to insure that the various language versions of your pages are indexed is to use the sitemap. Otherwise the search engines would only discover the pages by trial and error (the same as they would discover the pages without a language specifier.)

    The `dynamic-locale` plugin is required also to have sitemap generate multiple language versions of the urls.
  • I have dynamic locale plugin enabled with just use flags ticked, seo_locale plugin enabled and sitemap-extended enabled.
    mod rewrite ticked plus multi-lingual with 2 languages ticked.

    Still no multiple language versions created in the sitemaps :-(

    Any other ideas to get this working?
  • acrylian Administrator, Developer
    Zenphoto does not keep the language prefix in the url like That is only used for switching. You have to use subdomains if you wish to use static urls for each language.

    IF you haven't yet please read this tutorial:
  • Hi

    I have followed that tutorial exactly.
    I have just done another install and followed every possible instruction and still the sitemap does not generate multiple language versions of the urls.

    I have installed a test here:
    sitemaps here:

    I've been trying every possibility for hours and still can't get it to work.
  • Does anyone know what the problem can be?
  • All this works correctly, at least with the nightly builds. So the first step would be to install the nightly build and see if you still have issues.
  • Thanks for the reply

    I have just downloaded and installed

    Still the sitemap does not generate multiple language versions of the urls.

    I have a test here
    sitemaps here:

    I have made a user profile so you can see the settings i have made

    user: admin2
    password: adminpass
  • acrylian Administrator, Developer
    Ah, now I see. This is a missunderstanding. That is a sitemap index file that links to individual sitemaps for the items (albums, images , news, pages). These links were never meant to be multilingual. Look at the the individual sitemaps that contain the multilingual links.
  • Yes, i have looked at the individual sitemaps. They do not generate multiple language versions such as the one below
  • acrylian Administrator, Developer
    Try the current nightly build. That works for me (an older one did not, too).
  • Yes i tryed the current nightly build.

    After a lot of trial and error switching off and on several plugins i found that when i switched off the 'security-logger' plugin that the sitemap generated multiple language versions and worked. When i switched the security-logger back on it stopped working. Seems the security-logger plugin is stopping the sitemap working properly
  • acrylian Administrator, Developer
    I don't understand why that would be involved here but interesting find. Best you open a ticket on the bugtracker.
  • If that is the case (certainly security logger is not preventing the genration of the site map for me) then there must be some sort of errors generated. So you will need to find and report those errors.
  • I have looked into this for the last few hours and installed the last nightly build 4 times and each time the only way to get sitemaps to work fully with multilingual links is with security logger switched off.

    I tryed other versions of zenphoto and switching off security logger makes no difference and with those version i can't get sitemap to work at all with multilingual links.

    I checked for error logs with my host when having security logger switched on and off and as well using sitemap and there are none.

    I am really lost what the problem is exactly.

    I see that acrylian said it only worked for him with the latest nightly build but not older ones so there is maybe a problem somewhere. Was that working with security logger on?
  • By the way you can see for yourself on one install that i have up and running here:

    I have a test here
    album sitemap here:

    login details

    user: admin2
    password: adminpass
  • acrylian Administrator, Developer
    I was testing with the security_Logger enabled and just did again (same 11083 build as your test site) and it worked for me. Security logger settings are the default ones.

    So if there is no error anywhere I have no idea.
  • I just checked now and found some log errors with the hosting as bellow. Not sure if this means anything.

    [Sat Dec 08 21:19:43 2012] [error] [client] Use of uninitialized value in concatenation (.) or string at http-error.cgi line 73.

    [Sat Dec 08 21:47:02 2012] [error] [client] mod_mime_magic: can't read `/home/sites/', referer:

    [Sat Dec 08 21:47:07 2012] [error] [client] mod_mime_magic: can't read `/home/sites/', referer:

    [Sat Dec 08 21:50:55 2012] [error] [client] mod_mime_magic: can't read `/home/sites/', referer:
  • acrylian Administrator, Developer
    That means that Zenphoto on your site is not allow to write the logs because of some server security extension named "mod_mime_magic". That will be the reason why the security logger prevents the sitemap being generated properly as that is meant to generate a log. Nothing we can do about this. You need to contact your host or just disable the security logger.
  • Hi

    Thanks for your reply

    I contacted my host and reinstalled zenphoto and we went through it together. We sorted out some errors by changing the permissions of the setup.log file in zp-data. After reinstalling and trying out again with multiple languages i still have the sitemap problem.

    The host told me to refer back to you with the following quote:
    'I would liase directly with the developers, If it's something amiss with the software, it's going to be them that is able to resolve it. There must be some correlation between the security logger and the sitemap feature and they would know this.'

    I had the following errors this time in log if it helps:

    [Sun Dec 09 16:58:45 2012] [error] [client] PHP Warning: fopen(SERVERPATH/zp-data/debug.log): failed to open stream: No such file or directory in /home/sites/ on line 1024

    [Sun Dec 09 16:58:45 2012] [error] [client] PHP Warning: Missing argument 1 for reconfigureAction(), called in /home/sites/ on line 104 and defined in /home/sites/ on line 11

    [Sun Dec 09 16:58:45 2012] [error] [client] PHP Warning: fopen(SERVERPATH/zp-data/debug.log): failed to open stream: No such file or directory in /home/sites/ on line 1024

    I also installed zenphoto on my pc using xampp and also had the same issue with the sitemap.

    Do you have any suggestions what the problem could be?
  • acrylian Administrator, Developer
    The first and third error is either permissions again or the file is indeed missing. I have no idea about the 2nd one but might be a follow up of that.

    It is all working for me on MAMP as said. I cannot test XAMPP but sbillard is testing on windows (I think WAMP though) so I will have to pass on this. Maybe he has any idea.
  • The second error has been corrected in te nightly builds. It will happen only on the reinstall, though, so should not be a serious issue.

    DO you have log files? That is, can you see them with FTP? If so you are having read permissions issues. If not you are having file create permissions issues. If Zenphoto is not allowed to do its job it may not do it well.
  • Is it possible that the second error that is fixed now had anything to do with this issue? Is it worth reinstalling with latest nightly build?

    Do you mean the log files in zp-data? If so yes i have those. The file permissions are set to 600. I set those manually. I don't have any more errors as above but still sitemap not working with security_Logger switched on.

    The only errors i have at the moment are as below

    [Sun Dec 09 20:51:29 2012] [error] [client] File does not exist: /home/sites/

    [Sun Dec 09 20:51:29 2012] [error] [client] Use of uninitialized value in concatenation (.) or string at http-error.cgi line 73.
  • I have played around with your site a bit. I am sorry to say that at present it will not generate a multi-lingual sitemap no matter if the security logger is enabled or not.

    Please try modifying the `zp-core/global-definitions.php` file changing the next to last define (`DEBUG_PLUGINS`) from false to true. This will record the loading sequence of plugins to the debug log. Maybe that will tell us something.
  • Hi

    If you mean the install at

    I managed to get the sitemap working with securitylogger off using seo_locale and subdomains switched off as you can see here on sitemap:

    I changed the last debug_plugins to true

    Hopefully you can find the problem there
Sign In or Register to comment.