Editing an image


if i have 500 images in an album and and i want to edit the description of just one image then whats the easiest way to display the edit page of that particular image only (considering that one knows the file name).

the usual way of going through the album edit page and then selecting the image tab and then selecting the number of images to be displayed on a page to hunt for just one image in a big album is very time consuming.



  • acrylian Administrator, Developer
    The easiest is to search on your Zenphoto website itself and use the admin toolbox (every standard theme has that ususally on the top right if you are loggedin) to jump to the image directly.
  • Thanks Acrylian that was great! However this search thing has brought up another issue.

    The search on my site is working perfectly good except just one word. Its very strange that when i search for the word "Rakaposhi" the following error message comes:

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator, cgiadmin@yourhostingaccount.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.
    More information about this error may be available in the server error log.

    Apart from this its running fine with other words.

  • acrylian Administrator, Developer
    I doubt that this is really Zenphoto causing the error. Please contact your host if maybe some overactive server security is the reason.
  • contacted my host. the reply was:

    "I have changed php version to 5.3 and also corrected session path in php.ini file. But still the search option is still not working. Also there is no error logs to investigate further on the issue."

    what to do now? the search does not work for some words.
  • acrylian Administrator, Developer
    More info maybe what words do not work (special chars maybe?) and how your search is configured.
  • many words dont work like e.g. try "beach", "naltar" etc

    there are no special characters, just simple words.

    Regarding options:

    Author to Title fields are checked with Tags field set to "partial". All other fields are not checked.

    Treat spaces as "Space"

    Default search "within"
  • acrylian Administrator, Developer
    Are all images are cached so the search "knows" about them? Any errors in the log?
  • After the search error this is what comes in the log:

    {Fri, 21 Dec 2012 14:49:42 GMT}
    Backtrace: WARNING: session_start(): open(/home/users/web/b696/pow.khwajaharoon/htdocs/cgi-bin/tmp/sess_6a777cc251da5b348fed3b2a7cc9f8d0, O_RDWR) failed: No such file or directory (2) in /hermes/waloraweb079/b696/pow.khwajaharoon/htdocs/outzeal/zp-core/functions-basic.php on line 1508
    session_start called
    from zp_session_start (functions-basic.php [1508])
    from require_once (admin-globals.php [14])
    from admin-logs.php [8]

    I do see the images in the cache folder (vis ftp), is there a specific way to check?
  • acrylian Administrator, Developer
    If you see images/thumbs on your website there are cached ones generally. Did you switch to use sessions instead of cookies? Try switching then.

    I have no idea why the search would not work. But note that there is a search cache so if you made new tags they might not be covered. Set the search cache to 0 to test.
  • Your error message means that your server is mis-configuired. Specifically there is not a session folder configured. This is a Server/PHP thing so contact your hoster.
  • >> Set the search cache to 0 to test.

    Done -- No success

    >> Did you switch to use sessions instead of cookies?

    How do u do that?

    >> Contact Host (powweb.com)

    Already did, he said its ok on their part. Will contact again.

    Check this image: http://outzeal.com/index.php?album=trekking/photos/northern-areas-of-pakistan&image=150.jpg

    Its description says:

    "Closeup of a mountain peak known commonly as "Bull's Head" among the Northern area pilots."

    The search feature searches the word "closeup" and "pilots" but gives an error on others like "mountain" "peak" etc.
  • No other errors? Did you check your server error logs as well as the Zenphoto logs?

    There is something having to do with those search terms that is causing a fault somewhere. But only the logs can shed more information.

    I have a site on POWWEB and for sure doing a search for "mountain" is not a generic problem with the provider.
  • Hmmmm. I was playing around with this on your site and got the same problem you describe. So I tried with my site (that uses a custom theme) and didn't see any issue. So I flipped over to the zenPage theme. Searching for "mountain" got me two hits that displayed. Searching (within the search) for "the" spit out this...

    Notice: Undefined index: albumid in /path/to/my/site/zp-core/class-search.php on line 1408

    Fatal error: MySql Error: ( SELECT folder,`show` FROM `[prefix]albums` WHERE id = ) failed. MySql returned the error You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1 in /path/to/my/site/zp-core/functions-db-MySQL.php on line 59

    So I jumped back to my normal theme and tried the same searches. No problems.

    From the times the search fails and gives the error this can be found in my php error.log

    [23-Dec-2012 11:01:09 UTC] PHP Notice: Undefined index: albumid in /path/to/my/site/zp-core/class-search.php on line 1408

    Maybe it will set you on the right track.
  • Thanks Mark

    I just know basic HTML so cant really understand what to do after reading your post. If you can just tell me what changes to make and where, then I can try and see.
  • acrylian Administrator, Developer
    Both of you please always consider to upgrade to the latest release before reporting issues. respectively is not the latest.
  • sorry acrylian, i thought the overview page would notify about the latest release so didn't check the zenphoto's main website. The overview page still doesn't show that is released.

    Anyway I have downloaded now

    Just please confirm that is it ok to upgrade directly from to


    N.B. I've experience it twice during this week (even yesterday) that zenphoto.org webiste was not responding.
  • acrylian Administrator, Developer
    If you have the check for update plugin enabled there is a button on overview you have to push. I think in 1.4.4 Zenphoto will check itself and notify though.

    Yes, the site was a bit unresponsive recently.
  • Can i ugrade directly to from by skipping the inbetween versions?

    Yes the button is there but on pressing it says no connection with zenphoto. anyway i'll check this with the new version.
  • acrylian Administrator, Developer
    The no connection might be caused by our server that apparently timed out a few times on heavy (spam) load or whatever (our server admin is working on it but its holiday season).

    The upgread should not be a problem, it is within the same release stream that does not introduce real changes, just bug fixes. 1.4.3.x to 1.4.4.x might be more problematic (so far it seems not so much, of couse always depending on custom or 3rd party stuff).
  • ok i've upgraded to

    the words that were not searching before are now working but the search result page design is becoming all distorted.

    In www.outzeal.com
    Please try searching the word "mountain" and see what happens.
    However things are ok when you search "closeup".
  • The Zenphoto filesystem character define is UTF?8
    this does not give a green check while running the setup file. can this be a problem
  • The only definitive way of knowing what the file system character set is to do as suggested in setup--create the `charset_tést` file in the zp-data folder and let setup make its tests.

    But this is not your problem. The HTML of your page is wrong--


    Northern Areas of Pakistan



    The DIV after the paragraph tag is not closed (and is not allowed in that place anywy.)
  • if that's the themes/zenpage/search.php file then I uploaded it exactly as it was downloaded from zenphoto's website.

    I was unable to correct the div issue. There are 14 <div> and 14 </div>. I dont know which </div> is in the wrong place. Help required. thanks.

    But shouldn't the div issue affect all the search results?
  • the problem is probably comming from an album description. So it may not show for all results.
  • whats the solution
  • acrylian Administrator, Developer
    Indeed the div is not allowed there (and the inline css should not be there as well, align is obsolete in HTML5 btw).

    As to the solution check the album descriptions of the related albums.
  • this is getting beyond my scope.

    is this a zenphoto error or something at my end. I havent customized anything
  • acrylian Administrator, Developer
    You have to look at the album description on the backend. Use the html view button on the visual editor to see if there anywhere is this wrong html mentioned above. It is causing the layout issue only on this specific search result apparently. If you do a lot of editing in this editor it may create wrong html code. IF there are wrong nested or not closed elements the editor and also any browser will try to correct it "to make sense". This of cousre can result in the error you see.
  • The album description as seen through HTML editor is as follows:

    <div style="text-align: justify;"> album description </div>

    below the album description text box it states:

    Path: div

    Do you mean to say that this DIV tag should not be here in the album description i.e. the correct HTML should be:

    <p style="text-align: justify;"> album description </p>

    Path: p

    I created a new album and checked that the DIV does not show up in the code after writing any description. I dont know where has DIV come in all my album descriptions.
  • acrylian Administrator, Developer
    Sorry, I cannot answer that. Maybe you copied text from somewhere elese directly? That is not recommended anyway since it often carries unwanted formatting (from Word e.g.). So you need to remove these divs manually.
Sign In or Register to comment.