Setup Complete But Warning Message Appears

I've done all the setup steps but get this when I reload the setup page:

Warning: require_once(../../zenphoto-1.0.1b Folder/zen/auth_zp.php) [function.require-once]: failed to open stream: No such file or directory in /home/gwleigh/public_html/zenphoto/zen/setup.php on line 1

Fatal error: require_once() [function.require]: Failed opening required '../../zenphoto-1.0.1b Folder/zen/auth_zp.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/gwleigh/public_html/zenphoto/zen/setup.php on line 1

If anyone could explain this to me I'd be very grateful.


  • trisweb Administrator
    Looks like "../../zenphoto-1.0.1b Folder/" is the wrong part... if it worked, it should find it in /home/gwleigh/public_html/zenphoto/

    Did you tweak the paths? If so, set it to the second one, not the first one.
  • Yeah. Basically I renamed that 1.0.1b folder to just 'zenphoto' once I got it onto my server. I did that in order to get the URL listed for accessing the setup directions to work. So maybe that's the problem?

    I'm a little confused about what I need to change here exactly. Thanks for your help.
  • Latest: I changed the folder 'zenphoto' on my server so that it's now called 'zenphoto-1.0.1b Folder', and then input the following URL into my browser: Folder/zen/setup.php, which brought up a login page, along with a note that says: 'MySQL error: could not connect to the database server'

    Any ideas whether this was the right action to take, and if so, where am I supposed to go from that login page?
  • trisweb Administrator
    Have you edited the config.php with your database login information? If you get that error, it means the credentials are wrong and it actually can't connect, so double-check them.

    Also, if you changed the paths in functions.php at the top, you can make it just "zenphoto" again and it should work as long as it matches the actual folder name. (You did change the paths, didn't you? It's the only way for the 1st error to occur...)
  • I'm pretty confused at this point. I didn't realize you had to edit the config.php file. I tried putting my login info into that file but still get the same message about not being able to connect.

    I didn't change any paths that I'm aware of. I didn't do anything to function.php at least. When I first tried to go to the URL for the setup options, it couldn't find any folder called just 'zenphoto.' So I figured that the 'zenphoto 1.0.1b Folder' should be changed to just 'zenphoto.' When I did that, the setup instructions loaded so I assumed I had the right idea.

    Thanks for all your help so far.
  • trisweb Administrator
    Keep editing that login info until it does connect; if it keeps giving you the same error, then it's still incorrect. Look up the info from your web host, or give them an email.
  • It seems I have the same kind of problem. For testing purpose I'm trying to install it on my local machine. I installed mysql on my Mac and am able to log into the database through the terminal application.

    However if I put exactly the same login credentials into config.php, Zenphoto answers with "MySQL Error: Could not connect to the database server."
Sign In or Register to comment.