zenphoto 1.4.4 : images are not displayed in news/pages

vincent3569 Member, Translator

I installed the zenphoto 1.4.4 release (as usual, thanks for the really great job).

In news and pages, images from my gallery are not displayed.
You can have a look here http://dev.vincentbourganel.fr/news/photo-du-mois-decembre-2012
and here http://dev.vincentbourganel.fr/pages/materiel

I tried to do some debug, that you can see here : http://dev.vincentbourganel.fr/zp-core/i.php?a=images/photos-du-mois&i=img_4545.jpg&s=500&wmk=!&debug
and here : http://dev.vincentbourganel.fr/zp-core/i.php?a=images/illustrations&i=canon-7d.jpg&s=350&wmk=!&debug

Both, I have this message :
Zenphoto Image Processing Error: Forbidden(2)
is there an issue ?


  • acrylian Administrator, Developer
    Permission errors in your server log maybe? Safari reports:
    Failed to load resource: the server responded with a status of 403 (Forbidden)
  • vincent3569 Member, Translator
    unfortunatly, I have no error anywhere.
  • acrylian Administrator, Developer
    I have no idea. It works fine on our server (And that is a bit difficult wiht permissions as well).
  • This is an error in calling the image processor. There is a security change in 1.4.4 to prevent a denial of service attack instituted by the atacker generating i.php url requests.

    If you have "captured" an i.php url in your database you will have to re-edit that item to get a new url. (BTW, you really don't want to capture image URLs until they have been cached--otherwise the url will never change from the image processor.)
  • vincent3569 Member, Translator
    I don't have "captured" any i.php url. All url have been generated via the Zp icone of TinyMCE.

    I tried to insert the image again, still with Zp icone of TinyMCE.
    but the result is the same : I can't see any picture.
    for example, the src of the picture change from "/zp-core/i.php?a=images/photos-du-mois&i=img_4545.jpg&s=500&wmk=%21" to "/zp-core/i.php?a=images/photos-du-mois&i=img_4545.jpg&check=9ce8aded1c74ed12c652610a831a39b72e6b0e51&s=400&wmk=!"

    see the example here : http://dev.vincentbourganel.fr/index.php?p=news&title=photo-du-mois-decembre-2012 (the first link to the image).
  • acrylian Administrator, Developer
  • vincent3569 Member, Translator
    ok, but on my website, it doesn't work, and maybe, for many other users :-s
    so, what we can do to solve this problem ?
  • How about the url:

    that one is not security protected so it must be from before the 1.4.4 release. It will cause the forbidden error. There may be a different reason for the first image not rendering.
  • vincent3569 Member, Translator
    hi sbillard.
    as explain before, I gave you an example :

    - the second picture (`img_4545`) is the original code in my news, wich refers to image processor (I don't change anything after migration to 1.4.4).

    - However, the first picture (`img_4545`) is the new code generated by tinyMCE with zp 1.4.4, wich still refers to image processor, but with added code.

    I have the issue with older link to the image, but I have the but issue too with the new code generated...

    I have no problem of image in gallery part.
    I have no problem on pages when there is some php code to generate picture in Codeblocks(this page for example : http://dev.vincentbourganel.fr/).

    Maybe, there is a problem with ZP extention of TinyMCE ?
    this extention should generate cache image and create a link like `src="/cache/photos-du-mois/img_4545_500.jpg"`.
  • acrylian Administrator, Developer
    Indeed I can confirm the bug, it is only happening on the custom size option. All others seem to work fine:

    I have created a ticket.
  • vincent3569 Member, Translator
    thanks acrylian
Sign In or Register to comment.