How to install ZenPhoto on DreamHost: A Guide!



  • Dreamhost actually now has a one-click install of ZenPhoto, which even updates automatically when new releases come out.

  • NOTE: If you use Dreamhost one-click, you cannot do nightly build updates because no files reside in your install. I created my own MySQL databases, quite easy on DH, then installed the ZP files myself. They also have GUI interface to manage your databases using MyPHPAdmin. (My plan is their cheapie, and been very happy over last 8 years with them.)
  • aitf311 Member
    You probably shouldn't be doing nightly build updates unless you are building plugins and/or writing a translation, it can be buggy at times.
  • Or if you are suffering a bug that we told you is fixed in the nightlies. Anyway, we plan to release 1.1.6 sometime next week to get everyone back on an "official" release.
  • dd-b Member
    I don't see Zenphoto on the dreamhost one-click list today.

    (I installed it terribly easily by hand, though, before I found this thread. Just unpacked the .tar.gz file, changed the top directory name to what I wanted, created a database in the dreamhost control panel, hit the new directory with my browser, filled in my database information, and off we go!)
  • I have many domains hosted with Dreamhost, and I tried installing Zenphoto in 5 of them, they all have the same problem. Even after ensuring .htaccess had "RewriteBase /zenphoto" and uncommenting both the definition for WEBPATH and SERVERPATH (and setting appropriately), I still can't get this to work. When I load, it redirects me to and the browser displays "No input file specified.".

    This is quite frustrating as I installed it on my private webhost by just unzipping the archive to the appropriate folder and visiting the /zenphoto dir in a browser.
  • Oh, it's especially frustrating because another guy I know who hosts at Dreamhost installed the exact same way as me and it worked fine....I think there's some minor differences in either the httpd.conf or php.ini files between some of the webservers.
  • I deleted my .htaccess file, and it's working now...weird, now how to get mod_rewrite to work?
  • Alright, so I took the original .htaccess, commented out every line. Removed the hash mark, saved the file, reloaded the browser in order to determine that these lines are the ones that are screwing with my installation:

    # RewriteCond %{REQUEST_FILENAME} -d
    # RewriteRule index\.php$ index.php [L,QSA]
    # RewriteRule ^page/([A-Za-z0-9\-_]+)/?$ index.php?p=$1 [L,QSA]
    # RewriteRule ^(.*)/page/([0-9]+)/?$ index.php?album=$1&page=$2 [L,QSA]

    # RewriteRule ^(.*)/?$ index.php?album=$1 [L,QSA]

    That last one is the one that made it so I wouldn't even see the zenPHOTO Setup page.
  • Why not ask Dreamhost? They seem to have good working knowledge of zenphoto (since they made the one-click install).
  • aitf311
    Assistant Developer

    I've been doing nightly builds every night for ages, except recently when "life" interrupted my playing with ZP :) Any bugs were fixed by the terrific developers with the next build or so.

    I removed my Dreamhost .htaccess file when installing ZP. Other than that, zero problems, not had to modify anything specifically for install.
  • I have talked to the Dreamhost guys, but this basically boils down to the custom rewrite rules which they don't support. Removal of the .htaccess solves the functionality problem, but it does not allow you to use mod_rewrite. I thought maybe fiddling with the SERVERPATH constant might fix things but it did not.
  • True, long ago acrylian or sbillard found a problem I was having was mod_rewrite on so guess I've never thought of it again. But, never knew to associate with Dreamhost.
  • Dreamhost + PHP 4 + Zenphoto = "No input file specified" error.

    At first, I used the work-around mentioned here: Editing the .htaccess file and changing the "RewriteEngine" to "Off", I was able to run the setup.php file. However, the paths weren't setup correctly, so 404 errors were rampant. Just before giving up, I thought I'd check the PHP version I was using. Switched it from v.4.4.8 to v5.x, re-uploaded the .htaccess file with RewriteEngine set to On, re-ran the setup.php file once more, and boom! Works perfectly.
  • The information here seems aimed towards an earlier version of ZenPhoto. Are there updated instructions on getting ZP 1.2.4 to work as a manual install on Dreamhost?
  • I'm on the cheap sharing plan with Dreamhost. Zenphoto works fine. I installed manually following zenphoto's install instructions: just unzipped, created the db, and I was good to go.

    Something to check (I discovered this from support when I has having filesystem errors) is that the servers are not identical. You can be hosted on a machine that is using phpX and your neighbour is on a different machine that uses phpY. Same with vim (6.x on some, 7.x on others), and so on.

    I wonder if this might be why some are having troubles and others aren't.

    You might request that your site be moved to a different machine. It's straightforward for a small site and they are used to it since they are migrating everyone to new machines anyway. Just backup, make the request and wait an hour or two for them to confirm it.
Sign In or Register to comment.