Setup not working...


I hoping someone can help me. I've followed all the setup instructions and changed the config.php and .htaccess files. When I go to the setup.php and put in my login, I get a 404 error.

My setup.php is like this:

When I click the login button it tries to call up this page:

I can't work out why it's doing this, anyone got any ideas?

thanks in advance



  • trisweb Administrator
    Probably need to update the path in the .htaccess file, sorry that's not documented better.
  • I was having this exact same "cgi-system" issue... (I'm on Dreamhost)

    In .htaccess I set:
    RewriteBase /home/username/

    My ZenPhoto install is actually in and I had to leave off both the /zen and the trailing slash.

    In my Dreamhost control panel, I set the subdomain that I was running Zen on to run as PHP5.

    Once I did that, I went to setup.php and happily saw:

    database connected
    We’re all set to create the database tables: zen_photos_albums, zen_photos_images, and zen_photos_comments.

    Then after I got it all installed, I had to change in .htaccess to:
    RewriteBase /zen

    Can't tell you why it worked, but it did for me.
  • tsservo & trisweb,

    thanks for the response, I'm on dreamhost too so I think I must have the same problem as tsservo.

    I'll make those changes and see if that fixes things.


  • trisweb Administrator
    I think there's a problem with resolving those paths on dreamhost in 0.9. I'll see if I can fix it in a minor release soon if that doesn't work for you.
  • I changed the settings on the domain to run PHP5, and logged in and I got a different 404 error, as it tried to go here:

    instead of:

    I revisited the correct setup domain and I got the 'We're all set to create the database...' message and clicked GO!

    It then gave a choice of visting the gallery (which worked fine) and administrative settings which I got a 404 error again.

    I then change the .htacess as tsservo suggested to:
    RewriteBase /photos

    instead of the absolute path (which I had it set to in during the setup).

    It now seems to be fine, I'll no put some photos up and see if there are any other problems.

    A couple of comments for trisweb:

    When you have no photos or albums you get a missing image icon when you view it in Safari.

    The logout doesn't seem to work in Safari, but is fine in Firefox. In Safari it takes you to the gallery, but when you revisit the admin page it automatically logs you in. Could it be a cookie or cache issue? Can you add a check box to log, for remembering the login?

    One last point, the admin page says the version is 0.8, but I downloaded 0.9 - is this a know problem?

    thanks again

  • I'm on dreamhost too. Got the database to connect but when i'm presented with the admin login page and login it says

    "The requested URL /cgi-system/zen/setup.php was not found on this server.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."

    I've treid a variety of .htaccess changes to the absolute path (i've installed zen in and have tried /zen, /photos/zen, and some others) but none seem to change zen's desire to go to the/cgi-system folder. I've changed that hosted domain to PHP5, but nothing has changed. Any suggestions on the .htaccess settings?

  • cancel that last post. just took a while to get eveythink in sink. Sweet.
  • Can someone please explain the correct settings for RewriteBase??? No matter what I set it to I get 404's on selecting an album to view.
  • trisweb Administrator
    It should just be the path from your base url - like:

    If your URL is:
    Your RewriteBase would be: /stuff/photos
  • Ok, doesn't work. Try AGAIN!

    This is awful.

    The URL I have all my stuff under is http://mymachine/zenphoto

    So, I changed the RewriteBase to /zenphoto

    Still no luck whatsoever. As soon as I select an album I get the 404 not found. I can navigate to admin.php by putting in http://mymachine/zenphoto/zen/admin.php, but as soon as I try to change something, it attempts to redirect using the rewrite base again and I get another 404 not found.

    My album is named 'test'. When I click on it, I get this 404 error: "The requested URL /zenphoto/test/ was not found on this server."
  • Remeber, the "absolute path" is the whole path for the file on the server, not relative to the website. would be:
  • trisweb Administrator
    Consider the possibility that you don't have mod_rewrite available on your server, and turn it off in the config file. No pretty urls, but it might work...
  • May I also suggest you make sure you have AllowOverride All set in your apache conf file for the directory in question.

    I had symptomps similar to what you report until I changed this parameter (which makes .htaccess take effect).
  • I am on DreamHost and am having the same 'cgi' problem. I have set up a separate database for my gallery from my WordPress install, but don't want a subdomain. How can I follow tsservo's instructions (ie changing subdomain to PHP5) if I am on the same domain? Will it hurt my WordPress install if I change anyway? Is it worth waiting for version 1 and full WordPress integration?
  • Im having the same problems as the people above, and no matter what I try, I just cant fix it; please help!

    Im using Dreamhost (who I thought were great until this afternoon). I installed it, and it connects to the db, but when I log in (correctly) it tries to go to domain/cgi-system/zen/setup.php, which doesnt exist!

    I've tried for the last ~3 hours, and its driving me nuts! And although I'm bad at following instructions, I followed these to the T!
    Please help me to get this working, I can do wonders with CSS/javascript and would be willing to share my work! Thanks
  • I've been having difficulty install ZenPhoto as well. My host is Godaddy. Has anyone successfully installed it?

    I reach up to this level:

    zenphoto setup
    Creating tables...

    You can now View your gallery, or administrate.

    Upon clicking on "administrate", it takes me to a black page that reads "No input file specified."

    Any ideas?
  • I'm having the same problem when I run setup.php for version 0.9:

    `The requested URL /cgi-system/zen/setup.php was not found on this server.`

    I tried switching the mod_rewrite off in the config file but it didn't affect anything.

    I am also using Dreamhost.
  • please, help us.. :D
  • I missed it the first time around, it was buried between all the other posts, but tsservos solution worked for me:

    Strange solution, I wonder how he figured it out to begin with.
  • RogerUsh - Could you explain in more detail, especially about how to get the PHP5 running?

    Thanks.. :)
  • I looked under the Dreamhost control panel Knowledge Base (just one of the great attributes of dreamhost) for PHP5 and it pointed me to the "Domain > Manage Domain" area.

    I reposted full instructions here:
  • I found that switching to php5 solved the cgi-system problem and everything fell into place.
  • This Sucks!!!

    So many people having the same problem.....

    I have tried all kinds of turned off rewrite engines and all suggested rewrite base paths and no luck!!

    Still the same error:

    "Not Found
    The requested URL /cgi-php/zen/setup.php was not found on this server.

    Apache/1.3.33 Server at Port 80"
  • I don't know where to start. I'm having similar problems but I don't see a .htaccess files anywhere. I have turned on invisable files and see other .whatever files but no .htaccess. Do I need this? Shoudl I create one from scratch? I don't even know where to put it... in the root of my entire site, of my host (I have 3 domains on there) or on the root of the zenphoto folder?

    I am also on Dreamhost and would prefer not to use PHP5 so I can use their poll installation (which doesn't work in PHP5). However, I would like clean, search-friendly titles.
  • trisweb Administrator
    Bunglegirl -- yes, you need .htaccess if you want rewritten URLs. It should go in the root of your zenphoto installation.

    It might not have been copied if you're using a Mac or some other FTP client that hides dot-files.
Sign In or Register to comment.