Can not install Zenphoto

I have installed Zenphoto now.

Fatal error: Call to undefined function zp_loggedin () in / export/sd207/www/jp/r/e / ○ ○ server/5/6 / ○ ○ ○ / ○ ○ ○ .jp / zenphoto / zp-core / reconfigure. php on line 109

I can not go to the next in this description.

Do you have any good ideas?


  • Did the install complete?

    Any more details of the steps that lead up to this?

    The situation you are in happens if Zenphoto thinks things need to be re-setup when you are accessing one the gallery or the administrative pages.

    You can probably by-pass the problem by running the setup program directly from a URL link: `.../zenphoto/zp-core/setup/index.php`
  • I appreciate your advice.
    Fatal error did not go out, thanks.

    Welcome to Zenphoto! This page will set up Zenphoto on your web server.
    Systems Check:

    Installing Zenphoto v1.4.5.9
    zp-data security [is compromised]

    It is in this screen, it was accessed again by modifying some.

    The result was a 500 Internal Server Error.

    Representation of Japanese is not possible.
  • acrylian Administrator, Developer
    Japanese or any language to work excepet the "Native" English requires server gettext and locale support for this language. Otherwise it will not work. For example my own German server has only English and naturally German support.

    However, this missing should not cause fatal errors. Please check your file/folder permissions and post all errors you find in the server error log (ask your host where to look).
  • Is your native language Japanese?

    Sounds like your server cannot handle it for some reason. There are a number of flags at the bottom of the setup page. Click on the US flag for English and see if things work better.

    The original error can also happen as a downstream effect of other errors, so as acrylian has suggested, review your error logs for other errors that may indicate what the problem is.
  • I too am getting 109 on install. I'ver tried admin.php setup.php, installing from cPanel at my hosting location, and via FTP from a direct download from ZP...I am stuck.
    Thanks, Dave IN TX

    PS>..I can install via cPanel from host and install is successful. However, start receiving messages to upgrade....

    "Fatal error: Call to undefined function zp_loggedin() in /nnnn/nnnn/nnnnn/ on line 109"
  • PS>..I can install via cPanel from host
    This may well be the source of your problems. If you can, try to make a separate clean install of the current Zenphoto release. If that works then something the third party install software did is causing difficulties.

    Sorry, but we do not know what these cpanel routines do and have no way to help you debug issues they may cause. Perhaps you should ask your host to upgrade the cpanel install to the current version of Zenphoto.
  • I have completely deleted/cleaned the file system of any previous installs before each attempt, so the previous install has nothing to do with this failure.

    Then FTP'd to my host from a clean download from ZP.
  • I have completely deleted/cleaned the file system of any previous installs
    So you think the database cannot impact things? By clean install I mean NO remnants of any cPanel install.
  • Ok, DB was not deleted. I have just removed all DB parts—DB and DB user, and removed all ZP from file system.

    I will now start fresh again and FTP for another try...

    Thanks for your patience.
  • "Fatal error: Call to undefined function zp_loggedin() in /nnnn/nnnn/public_html/ on line 109"

    Received the above error again after removing DB, DB User_id, all ZP associated folders and file. I made sure I had a clean host before running /zp-core/setup.php. By the way, same error occurs when running /zp-core/admin.php

    Am I missing a step?

  • acrylian Administrator, Developer
    Are there other errors in the server error log?
  • Did you run the setup function via the direct link to `.../zp-core/setup/index.php`? If not please try that.

    Otherwise there will be some other error occurring. You will need to search all error logs to find what else is going on.

    Another thing to do is to edit the Zenphoto `version.php` file and add "-debug" to the version string. This will put Zenphoto into debug mode which will produce should produce a stack trace on the above error which may shed some light.
  • GOT IT!!! I found a mismatch in DB_User id's and fixed. The re-ran index.php and all went well. No errors, so I am on my way.

    Again, thanks for the patience...Expect my donation today.

    Dave in Texas.
  • I was able to install somehow Thanks.

    Mod_rewrite does not work server using my.
    I was able to install so if you delete .htaccess.

    There is one more problem.
    It is not possible to display Japanese.
    I've updated to the latest Japanese files already.

    Do you have any good ideas?
  • Your server software has to support the PHP gettext() functionality for any languages to work. For instance I have locally installed WAMP for testing. I found that with its 64 bit version languages did not work, but with its 32 bit version they did. No idea where the issue is, just went with the 32 bit one.
  • After checking in phpinfo(), GetText Support is enabled.

    Do I need to set something else?
  • acrylian Administrator, Developer
    I cite myself (bold added):
    Japanese or any language to work excepet the "Native" English requires server gettext and locale support for this language.
  • I asked the server company, they are not the locale support.

    Specifications of the server
    OS SUN Solaris 10 (SunOS 5.10) / 64bit
    Web Apache 2.2.23
    Mail Postfix
    Perl 5.8.4
    PHP 5.5.8
    Ruby 1.8.7
    Python 2.5.5
    MySQL 5.6.14

    Is it still impossible?
  • fretzl Administrator, Developer
    they are not the locale support.
    If you mean that your host does not support the Japanese locale(=language) then no, you will not be able to display anything in Japanese.

    Is your host Japanese or foreign?
  • My host is Japanese.

    Support representative on the server does not seem to know, it was a vague answer.

    I also so a beginner still, I am not understand with the server relationship.
  • acrylian Administrator, Developer
    Your host really should know about this. It is in any case server configuration. It would be very strange for a Japanese host not to have the Japanese locale installed.

    You can try this tool:
  • I have to try the list_locales.

    Http Accept Languages:
    Key  1.0-ja  
    code ja
    coef 1.0
    fullcode ja

    Supported locales:

    Where to do I change?
  • acrylian Administrator, Developer
    If you have Japanese apparently but it is not working something is not setup correctly. Only your host can help with that as this is server configuration outside of Zenphoto's responsibility.
  • All right.
    I will ask to my host.

    I appreciate your kindness.
Sign In or Register to comment.