Internal Server Error, installation problem

Hi all

After hacking my old web site, I have charge the last ZenPhoto version, but it is impossible start the setup; apper the follow message

"Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."

This is the link


  • acrylian Administrator
    check your .htaccess file. The easiest is to rerun setup.
  • in my .htaccess there is any words,i error log appear

    "[client] client denied by server configuration: /home/valentgj/public_html/.htaccess
  • fretzl Administrator
    Use FTP to delete your .htaccess file and run setup again.
    Let setup create a new .htaccess file. (there's a button on the setup page for that)
  • Now it work!, the problem was the uploading of the installer mode, uploading all the file with filzilla it work! thanks at all
  • uploading of the installer mode
    Could you be more specific about this. What did you use to upload the files when it failed?
  • Upload was made with original control panel of the hosting (CPanel) of the entire zip file, after it I have unzipped the package but without good results. the only way is to unzip all the file in the PC and upload all as singles files with a program like mozilla (I sudgest to specify it in the instructions of zenphoto installation)
  • Thanks for the details.

    Regarding the install instructions, it kind of does say what you suggest

    Of course we do not suggest a particular FTP client as that would depend very much on the PC platform you are running.
  • I had exactly the same problem.
    Got a 500 when I uploaded the zip and extracted using cPanels's File Manager.
    Extracting the files and than uploading worked for me.
    Thanks for this post!
  • Gosh I got a 500 on all the front end pages...
    The admin is fine though.
    I tried also without the .htaccess file but it just doesn't work.
  • acrylian Administrator
    If you wish to use the htaccess file and therefore modrewrite you need to enable the option as well. If it is disabled that could mean that your server does not support it and setup did it. If it is enabled and your server does not support it the links of course don'T work.

    Make sure you have the right htaccesss file. Btw, or 1.4.3 beta?
  • Hi acrylian.

    It's really odd.
    Even when in > options > general I disable mod-rewrite and delete de .htaccess file from the root on my server I get a 500 on all front end pages... what gives?

    I have version I have it running on my MAMP install.
  • 500 errors are often caused by the script file permissions being "too relaxed" for the server's requirements. For instance I will get them on my hosting server if the index.php file has permissions of 0777.
  • Thanks for realizing it had to be the index.php file.
    Everything front end related gets routed through this file right?
    I replaced the original index from the install, got back online, kinda.. no more 500's

    It's been a few months since Zenphoto and I made too many small adjustments that I can't remember now. Anyway I should upgrade to the latest version.
    Happy to be on a new host I can finally try out the subdomain localization!

    Thanks again for the help guys.
  • Yes, everything for the front end is handled by the root index.php file.
Sign In or Register to comment.