Odd too large msg Requested Entity Too Large

I have set
post_max_size = 96M
upload_max_filesize = 96M
including max_input_time = 80
All but about 1MB sized images are reported as to large. I'm doing one at a time and it does not get anywhere close to 80 sec of processing before the fail, more like 10sec after completing the import bar.
I've installed v1.5.6 on CentOS 7.6 and am running php72. 4G RAM is allocated with a couple of hundred G of diskspace and 4 cores.


  • acrylian Administrator, Developer

    These limits have nothing to do with memory issues regarding image processing: https://www.zenphoto.org/news/problems-with-albums-and-images/

  • steves Member
    edited April 2020

    Thanks, those are helpful!
    Sorry, I forgot to mention this problem occurs during upload.
    I made everyone of the suggested changes but still cannot upload a 6MB image. (BTW, hosting my own server right here.) Zen now has 12G RAM. Tried jpg's down to 1.84M with no luck. (Yes restarted after changes.)
    The upload progress bar runs all the way and then it say Request entity too large. Any other tips?

  • acrylian Administrator, Developer
    edited April 2020

    Tried jpg's down to 1.84M with no luck. (Yes restarted after changes.)

    If you read above you notice that hte file size is not the issue if this is really a processing one.

    Where exactly do you get this message and using what uploader? On the uploader/browser log (js error) or PHP error?

    Please post the complete error message if there is more (anonymized naturally).

  • steves Member
    edited May 2020

    The message appears when I try to use the menu option Upload, with the same result using either of the two upload options (http/jQuery).
    I select the album,
    ensure the Make a new Album box is not checked,
    click on Add files...,
    select an image file,
    click on Start upload.

    It then starts the upload with a progress bar. Once completed (2 seconds later) it then replaces the whole line where I picked the file with a red box and red text. The complete and exact error msg is:

    DSCF0030.JPG 4.68MB Error: Request Entity Too Large

    It has a trash icon at the end which does not appear to do anything.

    This is all in user land in the browser (same result with Firefox and Chrome).

    Above all of these is a yellow section that tells me that the maximum size for the total upload is 1GB.

    Sorry, I figured this was not an unknown error and did not go into enough detail.

  • acrylian Administrator, Developer

    Is there any other messge within the browser log (console) or PHP error log?

    I doubt this is a direct Zenphoto problem. If I understand right you run your own server. There are lots of option to set so I like to point to this quickly googled resourece https://www.keycdn.com/support/413-request-entity-too-large which seems to suggest there might be a server requerst limit in place that is additionally to the PHP limits you mentioned already.

    I never encountered this specific issue unless using really large/huge images. But I also never manage/configure my own server and lets webhosts do that (our own site runs on fairly normal webspace as well).

  • fretzl Administrator, Developer
    edited May 2020

    I came across this thread in the CentOS forum where a similar issue is solved by increasing SecRequestBodyLimit parameter in mod_security.conf

  • steves Member
    edited May 2020

    Thanks, interesting, but not sure how to reconcile that you don't have mod_security as a dependency nor do I have it installed. It, I'm guessing, would think there was something wrong and block it. But here with it not being installed makes it not look like the correct why.

    Looking at log files I see:
    2020/05/01 13:22:04 [error] 1386#1386: *6 client intended to send too large body: 4684422 bytes, client:, server: localhost, request: "POST /zenphoto/zp-core/zp-extensions/uploader_jQuery/uploader.php HTTP/1.1", host: "", referrer: ""

    access.log - - [01/May/2020:13:22:05 +0000] "POST /zenphoto/zp-core/zp-extensions/uploader_jQuery/uploader.php HTTP/1.1" 413 586 "" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/77.0.3831.6 Safari/537.36" "-"

    Here we have the http error 413 (Request entity too large).
    PHP 7.2 is in use.

  • fretzl Administrator, Developer

    Have you checked the link @acrylian mentioned in his anwer above?

  • acrylian Administrator, Developer

    As @fretzl mentions the article I linked also refers to a requestBody setting indepently of modsecurity. Your server error is from the access log so it is a server side issue.

    Also check if you have other security extensions in place like suoshin or others. These are known to cause all kind of issues if set to strict.

  • steves Member

    No, I managed to miss that one. Which interestingly was the answer. There is a server default of 1M. I made it 0 for unlimited, and we'll see how that works out.

    Thank you guys for hanging in there with me!!
    I was getting ready to dump it and simply set up a ssh file share or some such.

  • steves Member
    edited May 2020

    In case my reply was not entirely clear, that was the answer. It now works. My ref to "we'll see how that works out" was in regards to operating with unlimited.

  • acrylian Administrator, Developer

    Glad you figured it out!

Sign In or Register to comment.