Subalbum missing, but then "New subalbum" already exists

On the last upgrade, I somehow have lost the subalbums.

In an album timeline, I can see a Subalbum "Adam". There should be a Subalbum "David". It's now missing.

If I SFTP onto the server, the subdirectories are all there.

How do I aks Zenphoto to rescan all of the directories again?

(I've had this problem for some time ... and am just getting around to asking, now).



  • fretzl Administrator, Developer

    I'm guessing here but did you check the number of "album levels to show" on the admin albums page? (Admin —> Albums)

  • acrylian Administrator, Developer

    The subalbum should be listed as a subalbum of the parent album on the backend. If it does not do that but exists on the file system, perhaps your upgrade was not performed correctly and you accidentally assinged another database which not yet have the entry.

    Zenphoto re-scans the albums folder by visiting the backend or the front end. Additionally you can use the utility button "database refresh".

  • @acrylian Thanks for the guidance.

    I've tried "database refresh", but don't see a change.

    I had seen warnings in setup about Litespeed, as opposed to Apache or Nginx. Now asking my web hosting provider, they don't support Apache or Nginx, so it will have to stay as Litespeed, if I stay on this host.

    The image files are in the directories, as they always have been.

    Do you have recommended procedure for a reinstall of some sort? (I've been relying on Softaculous for a while, although I could easily do something manually).

  • acrylian Administrator, Developer
    edited January 2

    Installers like Softaculous may be a problem and are known for issues in the past. We recommend manual installation on our installation page therefore.

    We officially suppport Apache only as we basically only test that. We could test Nginx but it all comes down to time resources. Litespeed we never tested at all. I know it worked in older times but we don't and can't test it. But as far as I know that is generally Apache compatible.

    In any case you should review all error logs you can find as also file/folder permissions may be the issue if an album is not seen (e.g. cannot be read). See our user guide on permissions.

  • Thanks for the help.

    Since it's so easy to manage files, I decided to remove the previous Zenphoto installation and database, and start over.

    It looks like we're back to normal. Expendiency wins.

  • acrylian Administrator, Developer

    Glad you managed it. But be careful once your site is setup and you have editing data in the backend on albums and images. You will loose those if you modife/move/rename folders on the backend manually. Zenphoot matches the database with the filesystem. So any folder changed directly and not via the backend will be considered new for Zenphoto on discover and loose all these contents.

Sign In or Register to comment.