Language change

Hi, everything in my Gallery is in English instead of my language (dutch). Changing the default language to Dutch doesn't do a thing. Also tried to change to http accept language, but everyhing stays in English.
Is there a way to change this as I like to use the contact form in Dutch.

Thanks al lot.

Comments

  • Thanks, tried everything, but strange thing is that I installed Zenphoto on different sites from the same ISP and had no problems at all with the language.
  • It is quite likely that support for non-English languages is missing from that site. Your first question should be did Setup mention anything about this?
  • No setup did not mention anything. Just got off the phone with my ISP and they told me gettext is installed, so that did not solve my problem either.
  • The other things needed are the locale settings for the server. If they do not have dutch setup, translation will not work.
  • Is there a way I can check this myselve ?
    Other option is to reinstall and see what happens, but can I make a backup of the Gallery and pages I created and copy it back after the reinstall without the chance of losing everything ?
  • acrylian Administrator
    See the link I posted above.
  • I think there is some expertise needed more than we here have. For instance, I have a local install where I cannot get language changing to work. I suspect it is because Windows does not have the appropriate language support installed, but I really do not know.
  • fretzl Administrator
    I have the same problem on my local Windows install.
    I've searched everywhere for a possible solution without success.
    But maybe this post might be of some help ?
    http://www.kipras.com/getting-gettext-to-work-in-apache-on-windows/96
  • Unfortunately, this suggestion does nothing for my installation. Must be something else needed.
  • What versions of PHP is everyone running? See http://bugs.php.net/bug.php?id=49349.
  • fretzl Administrator
    Yeah, I read about the bug.
    I'm on 5.3 now but I allready had this problem on 5.2.x
    (I think it was 5.2.10)
  • I was on 5.1 and had the problem. Found and updated WAMP to v2.1e which is PHP 5.3.4. Unfortunately, now I cannot enable gettext() support. The server does not complete initialization and there are no error messages in the log. Couldn't find a WAMP PHP 5.3, but given your experience, guess that would not have helped either.
  • Changed to the v2.1e 32 bit WAMP which comes with PHP 5.3.5. That works!
  • Dont ask me how or why, but I did a reinstall and it works now.

    Thanks for your support.
  • Hi,

    Had the same issue with gettext() on WAMP v2.1d (64-bit) and PHP 5.3.4.

    I found PHP 5.3.5 64-bit in this thread: http://www.apachelounge.com/viewtopic.php?t=3839

    Direct links:
    http://www.apachehaus.de/php-5.3.5-nts-Win32-VC9-x64.zip
    http://www.apachehaus.de/php-5.3.5-Win32-VC9-x64.zip

    Added it to WAMP by following this guide: http://www.wampserver.com/en/faq.php#q1

    Seems to be running fine now:)
  • Ok, so which one of these php 5.3.5 downloads did you use?
    I am now trying to get WAMP (64bit) going with php 5.3.5 without any success.

    I did follow the guide. But the files of the two downloads seem different and so far Apache has not decided to start with eithr one.
  • Hello,

    I have a similar problem : my local install of zenphoto with ubuntu PHP v5.3.6 is working as expected in freznch, but my network install on my QNAP NAS with PHP version: 5.3.10 is only in english...

    I just don't know what to try...

    Any help is welcome,
    Thanks,
    Vincent
  • There is nothing we can do to help you. If setup has not identified anything that needs correction (like missing `gettext()` support) then the issue is entirely with the server configuration. For that you will have to have a discussion with your service provider.
  • Oh thanks !
    That's the problem !
    I thought the php module was installed with the new php 5.3 i installed, but it was'nt in this package !

    Thanks again for everything !
    Vincent
  • Always good to pay attention to what setup reports!
  • Yes ! when i installed zenphoto I didn't know what gettext was for...
    I was lauching again the install setup when I red your post !
    Thanks again for everything !
    Vincent
Sign In or Register to comment.