Large images not populating/thumbnailing!

I am not sure why, but very large images do not seem to thumbnail/populate until you click the direct image URL.

link : http://vivithemage.com/zen/vivi/

gallery : 600T

you can see in the gallery, no images either, just the url/link :

http://vivithemage.com/zen/vivi/600T/

image does indeed exist :

http://vivithemage.com/zen/albums/vivi/600T/P1000014.JPG

Is there something I need to check to allow this large of images?

Comments

  • weird, I don't see any content in my thread...

    EDIT : nevermind, now I do.
  • acrylian Administrator
    Maybe you should the message in red above the form?..........

    Your image is huge and your server probably not able to process it because of that. Please see the troubleshooting.
  • Hrmmm, I am not seeing anything specific to my issue in troubleshooting.
  • You are kidding, right? You did not see #10, #11, and #25?
  • Oh yeah, I went through those, but they did not help. &debug just said no objects. Unless that IS an error?

    # 8.2 MP Image, 3571 x 2302 pixels => needs ~41.7 MB Memory

    I have the memory for these size images. My server has 8GB. Do I need to specify somewhere that I do have the memory available? I bumped PHP's limit to 250MB, no luck.
  • You will need to find your CGI log and see if anything is there. What is the exact text of the debug?
  • The Zenphoto object you are requesting cannot be found.
    Album: vivi/600T
    Image: &debug

    Where are the CGI logs? I have cPanel if there is a GUI way of getting at them.
  • acrylian Administrator
    Please ask your host where to fine the server error log. Note that setting the php memory to 250mb might not work, even if it is told. Aks your host about that as well.
  • Also, the error you got on the debug indicates that you did not enter the URL correctly. Please re-read the troubleshooting on that option.

    However, when I try to access the correct URL it seems to fail to access the i.php script. It is possible that your server is configured to not allow dynamic image feeds. But more likely it is failing to render the image, so the CGI logs are the thing needed.

    But you have quite large images. Probably bigger than needed (depends on what else you wish to do with them.) It is pretty common for servers not to be able to render such large images.

    Some people have had more luck in these cases with imagick. If you have such support you could try enabling that graphic library.
  • I was going to try imagemagick quick, since that is installed, but there does not seem to be an option to enable it in Options > Image.
  • Probably then one of the requiremens for imagick is not right on your server.
    Requires Imagick 2.1.0+ (Imagick 2.0.0+ requires PHP5)
    Imagick 2.3.0b1+ and ImageMagick 6.3.8+ suggested to avoid deprecated functions
  • Using apache 2.2, php 5.2.9, and imagemagick 6.6.7

    I know they're installed. Why isn't the option there? Do I need to reboot the server after installing ImageMagick?
  • acrylian Administrator
    Also note you also need Imagick, the PHP extension to access ImageMagick additionally. Of course if you installed something you need to restart the server.
  • Bounced the server, still doesn't show up.

    How would I enable php to access it? Is there a script I can run that will show me if I am ready/compatible?
  • acrylian Administrator
    Our setup script will tell you. As always the php function phpinfo() tells you all details about your server php config.
  • I am not getting anywhere wiht imagemagick...where would I look on the server for the CGI logs? It's my own, unmanaged server.
  • Are you sure that you have "Imagick" installed and not just "ImageMagick"? They are two separate things. Imagick is a PHP extension, which is what Zenphoto uses. If you are not seeing Imagick in `phpinfo()`, then it is not installed correctly.

    Where your CGI logs are depends on how you have set up your server. The `ScriptLog` directive sets where mod_cgi dumps its logs. Perhaps it is also possible that the errors are sent straight to `stderr`. We don't know your server setup, so we really can't say where they would be. You will have to find them yourself.
  • odd, apparently it's not installed.

    http://vivithemage.com/php.php

    ImageMagick and imagick are installed. I do a Yum Install ImageMagick or imagick and they already say installed.
  • You also have to add modules to php.ini and then restart PHP (and maybe Apache as well, but I don't think so). If you have the module installed and in php.ini, then I'm not sure what else could be wrong in particular. Your error logs might help you there as well. :/
  • Where do I add modules to php? I went through easyapache to rebuild, imagemagick was not listed.

    By the way, thanks for the help!!
  • I recently had to change my php settings to Single PHP.ini and then change my memory_limit in php.ini in public_html to memory_limit = 200M (originally tried 60M and wasn't enough) -- this was for a 9MB image. You might need more... not sure if this relates but just in case. Maybe you figured that part out already... I'm with Bluehost.
  • I'm not familiar with easyapache, but as I said before, you should add modules to the file "php.ini" (PHP's configuration file). I don't think that you have to recompile PHP every time a module is added either, just the process needs to be restarted.
  • Thanks again kagutsuchi.

    easyapache just shows me the options of what PHP can do, and the options were not there.

    How/what should I add into the php.ini file? Should I do the global one (What is the location for that?)?
  • Where your php.ini is located is dependent on your server as well. For modules, there is a module section where you should add imagick.so or imagick.dll (whichever one is appropriate to your system).
  • Sorry, now I have a bit more time to delve into this.

    Is it possible to not have to globally edit it? Or is that the only way? Once I find that php.ini file, or can I do it for my user account?

    Is there another way I could try this as well? Or is ImageMagick my only real fix?
  • acrylian Administrator
    It depends on your server and how it is setup. Some allow special php.ini files per directory and other allow setting php.ini settings via htaccess (like mine does). Best you contact your host.
Sign In or Register to comment.